Can't download files to NTFS drives using Google Chrome


My first post. I’m a new user to Fedora (Fedora 36), coming from Ubuntu 20.04.

Unfortunately I’m finding that Google Chrome doesn’t download files if the destination is a mounted internal NTFS partition, or if an external NTFS drive. It opens the gnome file manager for a folder, and I select one on an NTFS drive, but then nothing happens after the file manager window closes.

Firefox will download to the NTFS drives perfectly and I can read/write to them from all my other installed apps. Chrome will only download files to my Fedora Home directory and also works to my exFAT USB drive.

I’m using Google-Chrome version 101.0.4951.64 (Official Build) (64-bit) installed using DNF from what I believe is the Google-Chrome repository enabled in f36. I have this same Chrome version on my other laptop that is still running Ubuntu and I’m able to download to the same external drives without issue.

So I believe the issue seems narrowed down to Google-Chrome and NTFS, on Fedora.

I’d appreciate any advice and guidance, particularly if anyone else has experienced this.

Many thanks

EDIT @ 1700 AEST: I have just discovered I can download files to the root of the NTFS drives, but as soon as I select a sub-directory the download doesn’t happen.

1 Like

Further update. The same issue occurs when using Chromium. I’ve also tried uninstalling fedora-chromium-config and that has made no difference.

I’d really like to know if anyone else is experiencing this issue - solved or unsolved.


just to be sure, from the file manager, you can create a text file in a sub-directory of that NTFS drive?

Why NTFS? (poorly supported in Linux)

Can we an ls -l of one of the directories you can’t download to?

Yes, same problem here when I tried to change default download location in chrome in ntfs directory, the button choose is disable or grey, but oke in root drive ntfs.

I maybe wrong but I think it maybe because of new ntfs driver from 5.15 kernel and 20.04 is using an older kernel so I guess that’s why it’s working there. Can you check if it is working on Ubuntu 22.04 or not as it is using a newer kernel. Tbh I don’t know the solution to your problem. I have a dual boot so I regularly interact with the ntfs drive and it works fine for me.One thing I might suggest that try the Flatpak version of Chrome or chromium and see if its working and don’t forget to give proper permission to the flatpak for ntfs drive

I’ve noticed the same issue with Fedora 36 and btrfs.I haven’t tried with Firefox but with Chrome I can only download to the downloads folder.I’ve been moving downloaded files to where I wanted them to download.Just to add this is ls -l

total 0
drwxr-xr-x. 1 straycat straycat   0 Mar 20 04:06 Desktop
drwxr-xr-x. 1 straycat straycat   0 Mar 20 04:06 Documents
drwxr-xr-x. 1 straycat straycat 554 May 13 09:14 Downloads
drwxr-xr-x. 1 straycat straycat  46 Mar 26 00:21 Files
drwxr-xr-x. 1 straycat straycat   0 Mar 20 04:06 Music
drwxr-xr-x. 1 straycat straycat   0 Mar 20 04:06 Pictures
drwxr-xr-x. 1 straycat straycat   0 Mar 20 04:06 Public
drwxr-xr-x. 1 straycat straycat   0 Mar 20 04:06 Templates
drwxr-xr-x. 1 straycat straycat   0 Mar 20 04:06 Videos

There have in the past been some issues with the SELinux context on files for the system.

For me that was fixed by running sudo restorecon -rv / and allowing selinux to properly relabel the entire file system.

Your listing of ls -l seems to be for your home directory, and as I recall I had several thousand files under my home directory that were changed when I ran that restorecon command.

Thanks for the suggestion I just ran the command then tried to download a file and it offers to save the file but does not download or save anything.I can download to downloads and it works as it should.It could be a chrome issue as well.I don’t download a lot so I’ll check when chrome is updated again.I also tried downloading a file with firefox and it works as expected.

1 Like

Thanks for all the replies.

This is my directory listing of my NTFS partition, part of my laptop’s SSD. I dual boot (rarely) hence why I have this NTFS drive as my shared data drive for Linux and Win10.

drwxrwxrwx. 1 root root 0 Jun 14 2021 ‘$RECYCLE.BIN’
drwxrwxrwx. 1 root root 4096 Jul 2 2021 BACKUPS
drwxrwxrwx. 1 root root 0 May 13 17:10 CacheClip
drwxrwxrwx. 1 root root 0 Mar 30 2021 DATA
drwxrwxrwx. 1 root root 0 Jul 2 2021 Desktop
drwxrwxrwx. 1 root root 8192 May 11 15:08 Documents
drwxrwxrwx. 1 root root 12288 May 9 16:47 DOWNLOADS
drwxrwxrwx. 1 root root 0 Feb 6 2021 GOOGLE-DRIVE__
drwxrwxrwx. 1 root root 0 May 25 2021 Music
drwxrwxrwx. 1 root root 0 May 14 09:41 ‘New Tab_files’
drwxrwxrwx. 1 root root 4096 May 10 19:06 OneDrive
drwxrwxrwx. 1 root root 0 Feb 4 2021 OneDriveTemp
drwxrwxrwx. 1 root root 4096 May 13 18:02 PICTURES
drwxrwxrwx. 1 root root 4096 Mar 30 17:59 ‘System Volume Information’
drwxrwxrwx. 1 root root 0 May 30 2021 VIDEOS
drwxrwxrwx. 1 root root 0 Feb 4 2021 VIRTUALBOX

And this is an external NTFS USB drive
drwxrwxrwx. 1 mark mark 4096 Dec 5 09:40 ‘$RECYCLE.BIN’
drwxrwxrwx. 1 mark mark 4096 May 10 19:15 BACKUPS
drwxrwxrwx. 1 mark mark 4096 Jul 2 2021 ‘CORE FOLDERS’
drwxrwxrwx. 1 mark mark 8192 May 10 19:11 ‘LINUX Distros’
drwxrwxrwx. 1 mark mark 0 Feb 25 2016 Seagate
drwxrwxrwx. 1 mark mark 4096 Apr 26 2020 ‘System Volume Information’
drwxrwxrwx. 1 mark mark 4096 Jul 4 2021 ‘VIRTUAL BOX’

I’m convinced (as much as I can be with my limited knowledge of Linux) that this is not a permissions problem because I can right click in gnome file manager and create folders in any of my NTFS sub-folders, all my usual apps can read and write data to all the NTFS sub-folders, apps like GIMP, Darktable, Davinci Resolve, LibreOffice, etc. Firefox can download to any chosen NTFS sub-folder.

I haven’t tried Ubuntu 22.04 on my other laptop as I was planning to switch to Fedora but might see if I can try a running from a live USB.

Further Update: I booted up a live USB for Ubuntu 22.04 and installed the same, latest version of Google-Chrome-Stable and I was successfully able to download and ‘save as’ files to sub-directories in my NTFS drives. However I encountered a strange issue, that’s not for this forum, where in the gnome file manager window that pops up for selecting the save to location, the SAVE button was inactive and I had to go back up one level, select the now-active SAVE button and it took me back down to my target folder and the SAVE button was now active. A bit odd and was the same using Firefox.

Back in Fedora, I also tried installing Google-Chrome from an RPM downloaded from Google and the same issue persisted.

I’m experiencing a similar issue after upgrading from Fedora 35 to Fedora 36. I can save downloads from Chromium-based browsers to my home folder, but not to Samba shares or to my Google Drive folder that’s mounted through the GNOME accounts integration. The browser doesn’t produce any error messages after I select the desired folder, but the download never starts.

I’ve verified this problem occurs on two separate computers (both recently upgraded from Fedora 35 to 36) and affects Google Chrome, Vivaldi, and Brave browsers. Firefox doesn’t appear to be affected by the issue.

This seems to be a bug in Fedora 36 or Chromium but I’m not sure how to trace down the issue to file a bug report against the right component.

Looks like an issue with permissions.

I think it maybe because of new ntfs driver from 5.15 kernel

the new ntfs3 driver is not used as the default ntfs driver in fedora. the issue is not related to it.

Yes, it seems there is an underlying issue affecting multiple save targets–it doesn’t look like it’s NTFS-specific.

I also tried uninstalling thefedora-chromium-configpackage to see if that fixed the issue but it did not solve the problem.

fedora-chromium-config has nothing to do with ntfs permission. I believe you need to mount the drive with user permission or change the permission of ntfs drive with chown command.

Thanks for the info!

I discovered a common issue in my case–both the Google Drive folder and the Samba share that I’m having problems with are mounted using gvfs. The mount paths are /run/user/1000/gvfs/.... (Mark, I wonder if your NTFS partition was mounted in the same way?)

I have another Samba share that I’ve mounted through fstab and I can save downloads into those folders without an issue. So yes, if the mount is done in fstab (as suggested by your link Arun) then it seems to work.

It seems that the permissions on the gvfs-mounted Google Drive and Samba folders are correct because I can copy files from my home folder into those folders using Nautilus. I can also save downloads directly into those folders with Firefox. It’s just saving downloads from Chromium-based browsers into those folders that doesn’t work after upgrading to Fedora 36.

Hi automatyck

Thanks for your input on this but I no longer have this issue because I had to go back to Ubuntu. I just couldn’t get Fedora to play nicely with my NVIDIA card (I followed all the install guides - official and non-official) plus this Chrome downoad problem continued.

My Linux skills are just not up to playing with an amazing distro like Fedora, so I went back to the safety net of Ubuntu.