Can't create new entries in launcher menu

Hi people, I hope you can help me, I’ve tried every solution I’ve come across in google and Stack Overflow to no avail. I downloaded an application in compressed format (Eclipse IDE) and want to add the damn thing to the app menu. I’ve placed the file in ~/.local/share/applications and also in /usr/share/applications, given it execution permissions, validated and installed it through the desktop install command, nothing has worked. The file does not have any errors:

[Desktop Entry]
Comment=eclipse IDE

Every other app installed through dnf or snap has its entry in /usr/share/applications and works correctly on the app menu, what the hell is wrong with my system? Possibly a bug?


Try this way:

desktop-file-validate ~/.local/share/applications/*.desktop
update-desktop-database ~/.local/share/applications
sed -n -r -e "s/^Exec=(\S*).*/chmod +x \1/e" ~/.local/share/applications/*.desktop

You can also edit the default launcher from the package eclipse-platform.

1 Like

I’ve tried both commands before, but I still gave them a try again, of course to no avail.

Installing eclipse-platform didn’t add anything to the menu in the first place.

Note that files with the same name from ~/.local/share/applications override the ones in /usr/share/applications.
Also, some changes may require session reload (Alt+F2:r) or relogin.