Can't connect to wifi after update (bcm4360 with broadcom-wl driver)

Easy to fix with the suggested test build from koji. No problem anymore.


Was just looking into installing fedora 30 on my laptop when I came across this issue.

Has anyone tried using the 2.8 branch of wpa_supplicant from rawhide?

I used and work on my Mac same broadcom wifi card

1 Like

Downgrading specifically to wpa_supplicant-2.6-17.fc29.x86_64.rpm and then excluding wpa_supplicant in dnf.conf has been the only solution that worked for me so far. I’m using a MacBook Pro 7,1 and with this method I still have a few issues with WiFi but it’s very sparse.


The updated “wpa_supplicant” solves the issue (isn’t problem with the driver), if you don’t want wait the update you can download HERE :wink:


It would be nice to know when this updated package will be in the fedora30 repos. :slight_smile:

All updates must go through the Fedora QA (Quality assurance system). So, this update is now in “testing”. It needs users to test and confirm the fix—by providing positive or negative karma. When it receives the required karma, it will automatically be pushed to “stable” for all users to use.


Personally I can’t see the packaged yet, maybe waiting for replication.

I use a lot fedora-easy-karma is a CLI interface, the procedure I follow is:

  • install fedora-easy-karma
  • Update the package from testing, enabling temporaly with

dnf update --enablerepo=updates-testing packed

  • start fedora-easy-karma
    • You can give +1, -1, 0
    • and a Comment
  • You’re starting to receive e-mail about comment in the package


1 Like

I’ll have to wait for the official update to have broadcom WiFi (BCM43142 on a HP-Notebook) working again. Hope the official update will come soon.
Doing all mentioned above failed.

dnf update --enablerepo=updates-testing wpa_supplicant-2.8-1

Last metadata expiration check: 0:09:04 ago on Sat 11 May 2019 12:26:10 PM CEST.
No match for argument: wpa_supplicant-2.8-1


dnf install wpa_supplicant-2.8 --enablerepo=updates-testing

Last metadata expiration check: 0:00:35 ago on Sat 11 May 2019 12:26:10 PM CEST.
No match for argument: wpa_supplicant-2.8
Error: Unable to find a match

Downloading and trying to install it:

rpm --install wpa_supplicant-2.8-1.fc30.src.rpm wpa_supplicant-2.8-1.fc30.x86_64.rpm wpa_supplicant-gui-2.8-1.fc30.x86_64.rpm

Gives a real long list of conflicting packages. Tried to remove the old version first, but dnf wanted te remove a whole list of Python packages as so called “unused dependencies”, which they are not. So I’ll have to wait and I hope the official update will come really soon.

dnf update --enablerepo=updates-testing wpa_supplicant

should do it. Once the update is pushed to bodhi, it is pushed to the mirrors worldwide and that takes time. Please check again in a few hours or so.

I like to share my experience with Fedora 30 and Broadcom drivers. I am using an Acer 5742 with a Broadcom chipset. With Fedora 29 and the ‘wl’ driver my wi-fi was unstable. Waking from sleep it would refuse to connect, I was forced to reboot. On a reboot, sometimes I had to reboot a second time before it would connect.
When Fedora 30 Beta became available, I decided to try it, and performed a clean install. All went well. Wi-Fi was stable, so I decided to see how long this would last before I would have to install the Broadcom drivers. (I had noticed that with Fedora 29, Wi-Fi was stable during the installation, and during normal use after, I had connections issues, which forced me to install the Broadcom driver from RPMFusion). However with Fedora 30 beta and subsequently with the official release of Fedora 30, I am still enjoying a rock solid Wi-Fi experience, without the Broadcom driver.
That has been my experience with Fedora 30 and Broadcom.


The following did not work for me:

805  dnf update --enablerepo=updates-testing wpa_supplicant
806  rpm -qi wpa_supplicant
807  dnf repolist
809  reboot
810  akmods --force --kernel `uname -r` --akmod wl
811  modprobe wl
812  dmesg
813  dnf remove akmods-wl kmod-wl
814  rpm -qa | grep -i akmods
815  rpm -qa | grep -i broadcom
816  dnf remove wl-akmods kmod-wl akmods broadcom-wl
817  dnf install wl-akmods kmod-wl akmods broadcom-wl
818  dnf install  kmod-wl  broadcom-wl
819  history
820  dnf install --enablerepo=updates-testing  kmod-wl  broadcom-wl
821  modprobe wl
822  akmods --force --kernel `uname -r` --akmod wl
823  cd /lib/modules
824  find -iname 'wl.ko'
825  modinfo wl
826  insmod /lib/modules/5.0.13-300.fc30.x86_64/extra/wl/wl.ko
827  modprobe wl

My HW:
02:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)

rpm -e  --nodeps wpa_supplicant-Old_version-?.fc30.x86_64
rpm -e  --nodeps wpa_supplicant-gui-Old_version-?.fc30.x86_64
rpm -i wpa_supplicant-2.8-1.fc30.x86_64.rpm
rpm -i wpa_supplicant-gui-2.8-1.fc30.x86_64.rpm
1 Like

Hi all. I noticed the same problem with my MacBook Air laptop. Initially, after upgrading to FC30 my laptop wifi worked fine. A few days ago I did an update via the gui and it stopped working. Wifi turns on automatically and “sees” the available networks but it can not connect to any of them.

I read the entire thread on and according to them the bug still persists.

I connected my laptop via ethernet (I have the lightning-to-ethernet adapter) and I noticed there was an update to wpa_supplicant to wpa_supplicant-2.8.2 so I figured it had been fixed in the meantime. So I did a ‘sudo dnf upgrade’ via ethernet and the problem STILL persists.

None of the workarounds listed on this page worked for me so… I wait.

Thanks for all your efforts.

Yes, I’ve tried everything above too, and it still is an official bug. A good one; all possible workarounds solve someone’s problem, but none of them work for everybody!

I ended up fixing it with the Koji build, unfortunately I ran an update and wpa_supplicant updated to the new version in the repo (2.8-2), and I’m back to where I started…

1 Like

You can temporarily exclude the package from updates using the exclude=.. directive in the dnf config file (or the related repository file). More information in man dnf.conf on that. The repository files are stored in /etc/yum.repos.d/, while the dnf config file is /etc/dnf/dnf.conf. (Do rembember to undo this in the future when the correct package update has hit the repositories.)

1 Like

Facing the same issue.

I was having the same problem, and it got solved by using the COPR build as suggested in Common F30 Bugs.

The working COPR repository is dcaratti/wpa_supplicant, and one can use it by running

sudo dnf copr enable dcaratti/wpa_supplicant
sudo dnf update

After reboot the issue will be solved


Thank you! I have been searching for an answer on how to get the Broadcom BCM4313 card in my netbook working. This finally worked. :+1::+1:

1 Like