Can't Connect to Wi-Fi with 5.5.8-200 kernel, Intel 3168 wireless


With the two newer Fedora kernels in Fedora 31, I am unable to connect to wireless. I’ve tried to provide a decent amount of information below, and attached. What could I try next to either provide more info or potentially resolve this? Is this worthy of a bug report, or is something perhaps out-of-sync on my system?

Quick background:

My laptop has the Intel 3168 wireless chip which was affected by a kernel bug (link 1, below). I believe this was resolved around the 5.5.7 fedora kernel release (rhbz# 1800335). However, I’m still encountering issues with the newer kernel.

System: Motile M141 Laptop, Wifi: Intel 3168NGW [Stone Peak]

Primary Problem:

On kernel 5.5.8-200.fc31.x86_64 (I previously had the 5.5.7 kernel which also exhibited this behavior):
As soon as the computer starts, the airplane icon flickers on and off quickly and continues flickering and never connects to wireless. If i turn on airplane mode via keyboard combo then turn off, sometimes it goes back to flickering, sometimes it just shows an ‘empty’ wifi option in the gnome top-right menu (also empty. When I get the empty wifi option, I click on it and choose ‘Select Network’, then I get the Wifi networks / select a network popup, but no networks are shown.

Working State / Secondary Problem

With kernel 5.4.20-200.fc31.x86_64, wi-fi works fine but I do get an error message which I wonder if it might be related:
wifi works fine, connects automatically on boot-up
‘Software updates failed’ notification on start-up. After clicking, loads an info box titled ‘Failed To Update’ saying:

Detailed errors from the package manager follow:
Error calling StartServiceByName for org.freedesktop.fwupd: Timeout was reached


the usual workflow doesn’t generate a problem report notification, but at one point I did something that caused a problem report that I think is related. should i submit the problem report from the problem reporting tool?

Further background:

I’m using the default fedora software update to update. I had previously updated to kernel 5.5.5 and 5.5.7, but removed those packages as wi-fi wasn’t working in them either. I used a command like sudo dnf remove kernel\* 5.5.5-200.fc31\* each time.


(1) kernel bug for 3168:

Also noticed this thread, but didn’t seem to be quite the same:

1 Like

  If you will be bored, there i’d saw some patch proposed (idk if it’s work).

Hello @curiousvter
A couple of weeks ago I had the same problem with an Intel Wireless-AC 3168NGW: no wireless, when I updated to kernel 5.5.5
After some days, 5.5.6-201 come out and the problem gone away. I’ve still not had the chance to update to a more recent kernel since then.

I have the same chip in one of my computers. Same experience as alciregi. As of right now, the computer is running 5.5.8-200 without issue.

1 Like

Hi All! Thanks for the tips! I think I had a slightly different issue than the one linked above, which hasn’t yet been resolved in the Fedora kernel, or upstream either, I’m not sure. Anyway, I think I’ve found the right fedora and linux kernel bugzilla entries, duplicates in each actually. The BAD_COMMAND error seems to match with what I’m seeing, as well as the descriptions where the 5.4 kernels work but not 5.5. I wanted to post them here as FYIs. Any suggestions as to how I might best “nudge” this issue to somebody’s attention?

Fedora bugs (duplicates):

Kernel bugs (duplicates):

Woo! I just downloaded kernel 5.5.15-200.fc31 directly from and this issue has been resolved. It appears to have been fixed upstream in the linux kernel in the 5.5.15 release

1 Like