Can't connect to hosted services anymore on Fedora IoT

Ever since a couple of days ago, I can no longer use my services that I have hosted on my server. I’ll go to their URL, and I get a 522 error after about 30 seconds. I didn’t change anything in this time.

I have all of my services running in Podman containers, and they’re all running, and they’re all healthy. I can also ping my server’s URL, and can also send out pings from my server.

Things I tried:

  • Turning off the firewall
  • Updating and rebooting (tried that twice)
  • Checking to see if my router had blocked my server
  • Checking for failed services

I’m using Caddy for my reverse proxy, but I don’t think it’s an issue with that, because Caddy isn’t showing any errors. It doesn’t even show evidence of a connection in the logs.

Also, when I go to my server’s local address in my browser, it redirects me to HTTPS, and gives me a SSL_ERROR_INTERNAL_ERROR_ALERT error. That doesn’t cause anything to show up in Caddy’s log either.

Fedora IoT version: 38.20230502.0

Are you affected because of this change ?

Changes/SSHKeySignSuidBit - Fedora Project Wiki

I don’t think so? I’m not accessing my services over HTTPS. I have 80 and 443 forwarded on my router, and I access my services by going to

I figured it out! My public IP address changed when I rebooted my router, and my Cloudflare dashboard was still pointing to the old one. I just have to setup ddclient so it doesn’t happen again.

1 Like