Can't change email address

I modified my email address on FAS, but here on discourse, in the preferences, the email associated to my account is still the old one and I can’t change it.
What can I do?

1 Like

This requires an admin, which is currently this group of people:

@riecatnor @gbcox @msuchy @bex @bcotton @mattdm

We can’t change it either, apparently. I tried to change mine a while back.

Email is retrievied via OpenID when you log in. So simple log-off and log-in again should update your info from FAS. Should. I did not tried it.

Yes yes, I logged out and logged in, but in my profile I have:

Email: the old one
Associated Accounts: OAuth 2: the new FAS email

Oh. :slightly_frowning_face: I guess it is the FAS login plugin we use. Since this is a Discourse-hosted site, is it possible to open a support ticket and work with them on changing email addresses in the database?

Just a follow up.
Since I’m subscribed to other forums running on Discourse, the issue is also there. It seems that discourse doesn’t allow users to change their email address. This is sad.
The only exception was Ask Fedora, but there the only difference is that I am a moderator. So I suppose that an administrator can change the email here.

Sorry about the delay. I opened infra ticket 8616 to check about this.

1 Like