Can't boot into my fedora 31

Hi. I can’t boot into my fedora now and i don’t know why.
Whenever i try to boot i get this error

It says press enter for maintenance or ctrl+D to continue.
As a noob I don’t know what to do in maintenance section also if i press ctrl+D I get the same error.
I searched a little bit on internet.
I tried
set prefix = (hdp,gpt1)/boot/grub
Method but same error.
Is there any other method?
I think the problem occures after I removed primeOS from dual boot.
I removed it from grub using hrub customiser but forgot to execute (sudo update grub).

Can you provide some information on what you were doing when this happened? Was this after an update? Are you dualbooting with another OS?

As the error says: it is unable to find your disk. Did you change/update/modify anything disk related?

You removed the PrimeOS partition as well?

1 Like

@FranciscoD @alciregi
I was trying to remove PrimeOS that I had installed before.
First i deleted the main directory of primeOS (as they say to uninstall it)
Then I removed PrimeOS from grub using Grub customiser.

I didn’t change anything disk related

I had a similar situation when I deleted an LVM partition that was listed in /etc/fstab, without removing it from fstab.
Did you used to mount the PrimeOS partiton also when you were using Fedora?

I am not sure but i don’t think that PrimeOS was mounted while using fedora. I dual booted it. (Sorry if my reply is nub i dont know much about it)

@alciregi @FranciscoD
It’s not my first time uninstalling PrimeOS like this but this never happened before.
When i removed PrimeOS from grub using grub customiser, before leaving it asked me to save the changes and I did obviously.
But i forgot to upgrade grub from terminal. Maybe this caused this error??

1 Like

Are you able to boot a Live ISO?

I don’t think (but I’m not totally sure), because otherwise you were unable to boot Fedora as well (I think).

That’s the main problem. I don’t have any CD/DVD or bootable usb stick with me now. And due to lockdown I can’t do anything

And at least maintenace start?

Is this maintenance start?

Try to issue
cat /etc/fstab
(Sorry I don’t remember if these commands are available in emergency mode).

lsblk : command not found
When i direct write command
cat /etc/fstab it says no such file or directory.
There is a file named fstab.empty in /etc directory

1 Like

Sorry. It is possible that in emergency mode there are no mounted filesystems. I don’t remember which capabilities you have in emergency mode.

Isn’t there anything to do?
It’s ok if I have to reset whole OS. I can do that.
I just want my system to bootup
My all important files are stored in different partition than root so I don’t mind resetting it.

1 Like

Ah, yes, that’s generally what I do when I mess up grub. If you have all your data in a different /home partition and so on, reinstalling is generally the quickest way to get back to a working system :smiley:

Yeah but I’ll need a working system and a usb stick for that and I don’t have that.
Isn’t there anything i can do with what is left in my system?

Well we start by diagnosing the error then. That disk that cannot be found: what is it? Is it Fedora related? I suspect systemd not being able to find this partition is what is causing it to end up at the emergency shell.

Only the /root file system is mounted in emergency mode, which is probably why you can’t find any files in there. From man systemd.special:

        ¦  A special target unit that starts an emergency shell on the main console. This target does not pull in any services or mounts. It is the most minimal version of starting the system in order to acquire an interactive
        ¦  shell; the only processes running are usually just the system manager (PID 1) and the shell process. This unit is supposed to be used with the kernel command line option systemd.unit=; it is also used when a file system
        ¦  check on a required file system fails, and boot-up cannot continue. Compare with, which serves a similar purpose, but also starts the most basic services and mounts all file systems.

        ¦  Use the "" kernel command line option to boot into this mode. A short alias for this kernel command line option is "emergency", for compatibility with SysV.

        ¦  In many ways booting into is similar to the effect of booting with "init=/bin/sh" on the kernel command line, except that emergency mode provides you with the full system and service manager, and allows
        ¦  starting individual units in order to continue the boot process in steps.

Can you try to boot into (May not be able to, since it also seems to require mounting all devices, but it’s worth a try). During boot, stop the grub count-down, and add to the end of the kernel command line (Let us know if you need more instructions on this).

Edit: still looking, but perhaps there’s a way to mount individual partitions manually to get a working system in emergency mode and then edit fstab to fix boot.

1 Like