Can't boot from USB to live CD system

A while back I installed Fedora KDE on my laptop to begin my transition to linux, and today I wanted to install same system on my PC, but when I booted from my new USB, it showed something like start_image() returned Unsupported. It’s not because of secure boot, when I disabled it, I tried again and it shows the same error.

Can you boot that USB stick on your laptop?

If not - did you image the stick the same way as last time when you made one to image the laptop?

1 Like

Not so long time ago I installed Fedora with GNOME on my laptop, when I used the same stick on my PC, it showed the same error.

This error is not unusual with older machines. Updating the BIOS may solve the problem, but vendor support for older systems can be uneven. You should provide the details of your hardware for the benefit of others who encounter the same problem.

It can be useful to check for issues with your hardware by searching the Linux Hardware Database for your system.

You may need to update network hardware (or use an external USB network dongle).