Can't boot from Fedora ISO


Hi there,

I just got a Dell Precision 5530 about two weeks ago that came with Ubuntu 18.04 pre-installed. I tried to like Ubuntu, but want to go back to Fedora, had Fedora 16 - 20 on my Desktop for a long time and it was really nice (desktop was destroyed by lightning unfortunately).

I downloaded the KDE Sping of Fedora, used Disks application in Gnome on Ubuntu to remove the partition, created a new 4GB partition and restored the image onto that partition, then made it bootable.

When i try to boot into that ISO (after changing the BIOS settings to set the flashdrive as the first boot device), it boots into a Grub menu

This is the first time i see something like this happen, usually when booting from a CD / DVD / Flashdrive on older computers, it goes straight into the live system.
It shows something about EUFI next to the flash drive on the BIOS boot selection menu, not sure if that is useful or not, on the flashdrive itself, i’m seeing 4 directories, EFI, imges, isolinux and LiveOS.

Any suggestions on how to get it to boot into the Fedora Live system so that i can test it?

The problem is you restored the live image to the partition.
A live image is not a partition image, you need to write it to the drive directly overwriting the existing partition table:

1 Like

Going into Disk, there’s no option to do an image restore without first creating a partition (i’ve tried it with a 4GB partition and a 100% partition).
The startup disk creator application doesn’t want to open the ISO image at all for writing even though it works fine for other linux distro images.

I’ve done a sha256 validate on the Fedora KDE ISO and the hash matches that on the website, so i don’t think the image is corrupted.

Thanks for the link, will try the Fedora Media Writer

1 Like

See the hamburger button in the window title or use Nautilus context menu.


That worked, thanks!!

So far everything works out of the box on the live boot


Installation done, wow, that was the quickest install I’ve ever seen and everything is snappy


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.