Can't add weather in the notification panel after upgrading from gnome 41 to 41.3

I have tried this more than once on two devices with the same specifications, one of them is Windows 10 running Fedora 35 on a virtual machine, and I the second is a real hardware with Fedora 35 installed.
After upgrading from GNOME 41 to 41.3 I can’t add a weather widget to display on the notification panel and it still stays “select weather location…”
I have a 64bit i-5 and an old Nvidia card on both devices btw
Am I the only one facing this problem?


May be you want to check the Gnome Settings → Privacy → Location Service and make sure it active.


Can you clarify how you’re trying to add this? There are two ways:

  • using the default Gnome weather feature. This takes the location from the Gnome “weather” application. So please open that application and see what location is set there. If none (and automatic location isn’t working), you can manually set a location there. The panel will pick up this location and show you the weather.

  • using the open weather extension: again, you need to go to extension settings and set your location

1 Like

im using the default method by choosing the part that designated for that in the notification panel, then it opens the weather application normally and It chooses my area automatically and everything works in the application but nothing appears in the notification panel
Location service is enabled btw Through the settings, bc switching through the status menu does not work as well xD sometimes appears strangely opposite to what it is in the settings
attached photo:

works completely opposite

Did you use the weather app to set a location? Does that not work?

1 Like

yeah i tried to change it manually but it didn’t work either

Edit: I tried changing the location to another manually several times before it finally started working

thanks for ur help :smiley: