Canon LBP3000 printer problem - stuck at "Sending data to printer"


I have a Canon LBP3000 laser printer connected to the computer, running F32, KDE Plasma.

It won’t print anything. I don’t really know what to look for to fix this, where to check, nothing, my understanding of printing under Fedora and Linux in general is far beyond my knowledge and understanding.

I guess some CUPS service is responsible for printing.

Under localhost:631/printers/LBP3000?which_jobs=all all jobs, so far it has only been test pages, are stuck at "Sending data to printer."

Any ideas on how to fix this?

1 Like

Check the output:

sudo ls -l -R /etc/cups; sudo grep -v -e ^# -e ^$ /etc/cups/printers.conf
[ugabrovec@office001 ~]$ sudo ls -l -R /etc/cups;
[sudo] password for ugabrovec: 
total 140
-rw-------. 1 root lp     129 Oct  9  2019 classes.conf
-rw-------. 1 root lp     129 Oct  6  2019 classes.conf.O
-rw-r--r--. 1 root lp       0 Aug  5 09:36 client.conf
-rw-r--r--. 1 root root 26189 Feb  1  2020 cups-browsed.conf
-rw-r--r--. 1 root root 29373 Mar 23 07:38 cups-browsed.conf.rpmnew
-rw-r-----. 1 root lp    2996 Aug 14 15:59 cups-files.conf
-rw-r-----. 1 root lp    2996 Aug  5 09:35 cups-files.conf.default
-rw-r-----. 1 root lp    4659 Oct  6  2019 cupsd.conf
-rw-r-----. 1 root lp    6278 Sep 13  2019 cupsd.conf.O
-rw-r-----. 1 root lp    6274 Aug  5 09:35 cupsd.conf.default
-rw-r-----. 1 root lp    6274 May 21 10:25 cupsd.conf.rpmnew
-rw-r--r--. 1 root lp       0 Aug  5 09:36 lpoptions
drwxr-xr-x. 2 root lp    4096 Aug 19 17:29 ppd
-rw-------. 1 root lp     588 Aug 19 17:29 printers.conf
-rw-------. 1 root lp     592 Aug 19 17:28 printers.conf.O
-rw-r--r--. 1 root lp     142 Aug  5 09:35 snmp.conf
-rw-r-----. 1 root lp     142 Aug  5 09:35 snmp.conf.default
drwx------. 2 root lp    4096 Aug  5 09:35 ssl
-rw-r-----. 1 root lp     112 Aug 21 17:25 subscriptions.conf
-rw-r-----. 1 root lp     526 Aug 21 14:06 subscriptions.conf.O

total 24
-rw-r-----. 1 root lp 12688 Aug 19 17:29 LBP3000.ppd
-rw-r-----. 1 root lp  5286 Aug 19 17:25 LBP3000.ppd.O

total 0
[ugabrovec@office001 ~]$ sudo grep -v -e ^# -e ^$ /etc/cups/printers.conf
NextPrinterId 2
<DefaultPrinter LBP3000>
PrinterId 1
UUID urn:uuid:2aeeca6c-8f8c-312c-59c8-b2a97bf8130e
AuthInfoRequired none
Info Canon LBP3000
Location office001
MakeModel Canon LBP3000 CAPT ver.1.5
DeviceURI usb://Canon/LBP3000?serial=0000A18108DW
State Idle
StateTime 1597850947
ConfigTime 1597850941
Type 8392836
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer

Based on this TOPIC

and adaptid from the REPO Doc:

Canon LBP3000 (CNCUPSLBP3000CAPTK.ppd)


  1. Go to the Canon Asia website (or any other Canon website) and download the CAPT Printer Driver for Linux V2.71 from this link.
  2. Extract it to get a folder containing directory 64-bit_Driver/RPM, enter inside.
  3. Install the package
sudo dnf install cndrvcups-capt-2.71-1.x86_64
sudo dnf install cndrvcups-common-3.21-1.x86_64
  1. Restart the printer.
sudo systemctl restart cups.service
  1. Add printer and start the Canon Printer daemon.
sudo /usr/sbin/lpadmin -p LBP3000 -m CNCUPSLBP3000CAPTK.ppd -v ccp://localhost:59787 -E  
sudo /usr/sbin/ccpdadmin -p LBP3000 -o /dev/usb/lp0
sudo systemctl start ccpd.service
sudo systemctl status ccpd.service
  1. Check the printer status.
captstatusui -P LBP3000

also you can get more info inside the README file from README-capt-2.71UK.txt in the Doc Directory.

Regards., HTH


You do realize this topic is over a year old?

Wasn’t solved though. So no harm done. Discourse by design does not close topics until they’ve been solved.

In general, we’d prefer that you flag the topic to ask a mod to close it if it’s old instead of making a remark of this type, which can considered snide/rude.

It’s still not solved! I will see when I get home, I’m @work ATM…

1 Like

Yes, I’ve had noticed but based on research in another TOPIC and its possible benefit for this one I’ve had revived it and preventing future questions about it.

In General, it is not a bad habit to revive topics if after a certain time without an answer, is considered or is thought to have a solution to it, especially preventing possible future questions, is considered or is thought to have a replay to it, and keeping in mind the number of questions about installation/ configuration problems on the LBPXXXX can be beneficial…


1 Like

OK, thanks for reviving this topic. However, the above mentioned does not solve the problem…

Could it be, that my printer is connected to a “wrong” USB port? Any ideas how to check that, apart from pulling out all the cables and going step by step through the ports?

EDIT: Even after trying to print something

captstatusui -P LBP3000

window is empty. There should be some information about what’s going on with the printer, right? :wink:

OK, I dug deep & found the solution.

Don’t really know how to explain, so I’ll use simple words. I did a lot of Google searches & carefully went through all outputs related to printers in the Terminal.

captstatusui -P LBP3000

was giving me a “Communication Error”. Printer was “installed as an USB device”, in CUPS the connection was


I changed that to



sudo systemctl restart ccpd.service

And it’s working now!

captstatusui -P LBP3000

also reports “Ready to Print”.

Hope it helps someone else. Best regards and thank you all for all the efforts!

1 Like