Cannot upgrade to 40 base image

Hello,

I am trying to upgrade a system to a CoreOS 40 based image, unfortunately it fails to find a gnutls-utils package that is compatible with the gnutls package from the base system. I tried an override replace but it seems not implemented.

# rpm-ostree status
State: idle
Deployments:
● ostree-unverified-registry:registry.gitlab.com/posttenebraslab/ptl-infra:main
                   Digest: sha256:9a604cc1763c395817a2d00dfa3082e79162959946250cfeca1b6dd20f92a668
                  Version: 39.20240407.3.0 (2024-04-24T22:06:44Z)
      RemovedBasePackages: nfs-utils-coreos 1:2.6.4-0.rc5.fc39
          LayeredPackages: btrbk ipa-client libvirt qemu virt-install
# rpm-ostree upgrade 
Pulling manifest: ostree-unverified-registry:registry.gitlab.com/posttenebraslab/ptl-infra:main
Checking out tree 5d89c92... done
Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora updates-archive
Importing rpm-md... done
rpm-md repo 'fedora-cisco-openh264' (cached); generated: 2023-12-11T14:43:50Z solvables: 4
rpm-md repo 'updates' (cached); generated: 2024-05-14T01:21:36Z solvables: 12864
rpm-md repo 'fedora' (cached); generated: 2024-04-14T18:51:11Z solvables: 74881
rpm-md repo 'updates-archive' (cached); generated: 2024-05-14T01:43:28Z solvables: 11711
Resolving dependencies... done
error: Could not depsolve transaction; 1 problem detected:
 Problem: package libvirt-client-10.1.0-1.fc40.x86_64 from fedora requires gnutls-utils, but none of the providers can be installed
  - package gnutls-utils-3.8.5-1.fc40.x86_64 from updates requires gnutls(x86-64) = 3.8.5-1.fc40, but none of the providers can be installed
  - package gnutls-utils-3.8.5-1.fc40.x86_64 from updates-archive requires gnutls(x86-64) = 3.8.5-1.fc40, but none of the providers can be installed
  - package gnutls-utils-3.8.3-2.fc40.x86_64 from fedora requires gnutls(x86-64) = 3.8.3-2.fc40, but none of the providers can be installed
  - cannot install both gnutls-3.8.5-1.fc40.x86_64 from updates and gnutls-3.8.4-1.fc40.x86_64 from @System
  - cannot install both gnutls-3.8.3-2.fc40.x86_64 from fedora and gnutls-3.8.4-1.fc40.x86_64 from @System
  - cannot install both gnutls-3.8.5-1.fc40.x86_64 from updates-archive and gnutls-3.8.4-1.fc40.x86_64 from @System
  - package libvirt-10.1.0-1.fc40.x86_64 from fedora requires libvirt-client = 10.1.0-1.fc40, but none of the providers can be installed
  - conflicting requests

libvirt and virt-install are the ones requiring gnutls-utils transitively. Of course removing them works, but I need them unfortunately.

Thanks for the great distro!

I think this is due to some inconsistencies in the repos that should resolve itself in the next stable release.

To test this theory you could try switching to testing temporarily.

Thanks, switching to testing did work, and I was able to switch back to stable after yesterday’s release.

2 Likes