Cannot run mongo using podman on silverblue

Testing out the waters with silverblue and podman and hit this issue running rootless. I can seeminly run many other database systems via podman (mysql, mssql etc.) without issue but mongo will not run. I am running silverblue on hyperv on windows. Was able to boot a current version of ubuntu, install podman and run mongo with the same command so seems to be an issue with silverblue (or maybe fedora in general).

Also tried --privileged and same issue but sudo can start it up.

podman info
host:
BuildahVersion: 1.9.0
Conmon:
package: podman-1.4.4-4.fc30.x86_64
path: /usr/libexec/podman/conmon
version: ‘conmon version 1.0.0-dev, commit: 164df8af4e62dc759c312eab4b97ea9fb6b5f1fc’
Distribution:
distribution: fedora
version: “30”
MemFree: 249290752
MemTotal: 8260423680
OCIRuntime:
package: runc-1.0.0-93.dev.gitb9b6cc6.fc30.x86_64
path: /usr/bin/runc
version: |-
runc version 1.0.0-rc8+dev
commit: e3b4c1108f7d1bf0d09ab612ea09927d9b59b4e3
spec: 1.0.1-dev

Have you tried comparing the versions between Ubuntu and Silverblue? Given that it works with sudo, I’d guess this might be an issue with rootless podman.

Yes, there was a version difference and 1.5 not in the fedora repos yet but I built from source and same issue. Did also have the same issue on fedora workstation vm so not a silverblue issue but fedora in general. Seems rootless podman on ubuntu does use native overlayfs while others like fedora can only use fuse so may be related, going to open a issue on podman github I guess.

In case anyone else has this or something similar. Found out it is a regression with fuse-overlayfs 0.5. Fixed in 0.5.1.

2 Likes