Cannot play *any* videos after upgrading to Fedora 35 anymore without Bluetooth headset?

I upgraded from Fedora Silverblue 34 to Fedora Silverblue 35 and then used the simplified packages to keep rpm-fusion stuff on the next upgrade, hopefully.

What does not work

However, now I cannot play any videos at all. Tried with:

  • layered Firefox and multiple websites, including YouTube
  • what’s worse, even the Flatpak-version of Firefox (which AFAIK includes all codecs) does not work! Also tried with Netflix here.
  • I even tried Tor Browser installed via Tor Browser Launcher via flatpak. Did not work.
  • And I also tried the a Ungoogled Chromium installed via flatpak.

What’s funny is that I can sometimes see the first 1-2s being played and I can always skip to some part of the video and it shows me the correct screen, it just does not play.

Local tries:

  • what’s worse, I then tried a local mp4 file with – according to Nautilus – H.264 (Constrained Baseline Profile) video and MPEG-4 AAC audio. It also could not be played with the same result. I can jump and see single frames, but it won’t play.
  • I then tried VLC from flatpak and this finally could play the video, but I did not hear any sound.
    So I noticed that also the GNOME sound settings will show me the laptop speakers as wanted. However, when I press the test buttons, I can hear nothing.

So actually audio seems to be the problem and not video!

The crazy “solution” (not actually one)

Note I also have aptX support installed from rpmfusion and strangely did not need to uninstall/remove it during upgrade.

So, however, when I connect my Bluetooth headset, everything works again. In VLC I can hear sound and all videos in Totem and the browser play without any problem. :laughing:
That’s soo crazy.


I do have all packages layered from rpm-fusion that I know of that are/were needed.

$ rpm-ostree status -v
State: busy
AutomaticUpdates: stage; rpm-ostreed-automatic.timer: no runs since boot
Transaction: upgrade (download only)
  Initiator: client(id:gnome-software dbus:1.112 unit:app-gnome-gnome\x2dsoftware\x2dservice-2630.scope uid:1000)
● fedora:fedora/35/x86_64/silverblue
                   Version: 35.20211116.0 (2021-11-16T16:10:17Z)
                BaseCommit: e4e8ccd21ff3774df1aa44557beaafde077672f8f2308b096baf89ff19eb3a2a
                            ├─ repo-0 (2021-10-26T05:31:27Z)
                            ├─ repo-1 (2021-11-16T15:45:05Z)
                            └─ repo-2 (2021-11-16T15:47:19Z)
                    Commit: db23e4bcb82a1fad08fc37490ca22973ee0e8b1dc25abf2854051b1e3c340cdb
                            ├─ fedora (2021-10-29T10:17:40Z)
                            ├─ rpmfusion-free (2021-10-23T21:56:55Z)
                            ├─ fedora-cisco-openh264 (2021-09-21T18:07:30Z)
                            ├─ updates (2021-11-16T16:27:23Z)
                            ├─ rpmfusion-free-updates (2021-11-14T20:59:55Z)
                            └─ updates-archive (2021-11-16T16:58:23Z)
                    Staged: no
                 StateRoot: fedora
              GPGSignature: 1 signature
                            Signature made Di 16 Nov 2021 17:10:26 CET using RSA key ID DB4639719867C58F
                            Good signature from "Fedora <>"
       RemovedBasePackages: pipewire-pulseaudio 0.3.40-1.fc35
           LayeredPackages: httpie git keepassxc gtkhash-nautilus sushi heimdall git-subtree firewall-config
                            podman-compose tldr simple-scan rpmfusion-free-release nextcloud-client htop dconf-editor
                            gnome-tweaks adb nvme-cli openssl nautilus-image-converter mozilla-openh264
                            gstreamer1-plugin-openh264 git-credential-libsecret smartmontools zsh
                            nextcloud-client-nautilus compat-ffmpeg28 lshw kid3


Lenovo Lenovo IdeaPad 5 15ARE05
Fedora Linux 35.20211116.0 (Silverblue)
AMD® Ryzen 7 4800u with radeon graphics × 16

More debugging

I manually neeeded to enable the plugin for OpenH264 in about:addons in Firefox and could double-check in about:plugins that it is installed. This did not solve anything. shows mostly ticks:


I see a similar report here, however, that seems to be a simple one, because the flatpak Firefox does work there.

aptX HD

So aptX is clearly used for the Bluetooth connection:


It is not listed as a LayeredPackages though, which is surprising (see rpm-ostree output above).

And I cannot uninstall it:

$ rpm-ostree override reset pulseaudio-module-bluetooth --uninstall pulseaudio-module-bluetooth-freeworld
error: Package/capability 'pulseaudio-module-bluetooth-freeworld' is not currently requested

I just see now that I can install it:

$ rpm-ostree install pulseaudio-module-bluetooth-freeworld
Checking out tree e4e8ccd... done
Enabled rpm-md repositories: fedora rpmfusion-free fedora-cisco-openh264 updates rpmfusion-free-updates updates-archive
Updating metadata for 'fedora'... done
Updating metadata for 'rpmfusion-free'... done
Updating metadata for 'fedora-cisco-openh264'... done
Updating metadata for 'updates'... done
Updating metadata for 'rpmfusion-free-updates'... done
Updating metadata for 'updates-archive'... done
Importing rpm-md... done
rpm-md repo 'fedora'; generated: 2021-10-29T10:17:40Z solvables: 65732
rpm-md repo 'rpmfusion-free'; generated: 2021-10-23T21:56:55Z solvables: 521
rpm-md repo 'fedora-cisco-openh264'; generated: 2021-09-21T18:07:30Z solvables: 4
rpm-md repo 'updates'; generated: 2021-11-20T00:59:50Z solvables: 10624
rpm-md repo 'rpmfusion-free-updates'; generated: 2021-11-14T20:59:55Z solvables: 49
rpm-md repo 'updates-archive'; generated: 2021-11-20T01:23:39Z solvables: 10017
Resolving dependencies... done
Applying 1 override and 172 overlays
Processing packages... done
Running pre scripts... done
Running post scripts... done
Running posttrans scripts... done
Writing rpmdb... done
Writing OSTree commit... done
Staging deployment... done
Freed: 3,5 GB (pkgcache branches: 169)
  breeze-icon-theme 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-filesystem 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-karchive 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kauth 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kbookmarks 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kcodecs 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kcompletion 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kconfig-core 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kconfig-gui 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kconfigwidgets 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kcoreaddons 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kcrash 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kdbusaddons 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kdoctools 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kglobalaccel 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kglobalaccel-libs 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kguiaddons 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-ki18n 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kiconthemes 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kinit 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kio-core 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kio-core-libs 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kio-doc 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kio-file-widgets 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kio-gui 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kio-ntlm 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kio-widgets 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kio-widgets-libs 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kitemviews 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kjobwidgets 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-knotifications 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kservice 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-ktextwidgets 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kwallet 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kwallet-libs 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kwidgetsaddons 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kwindowsystem 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-kxmlgui 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-solid 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-sonnet-core 5.87.0-1.fc35 -> 5.88.0-1.fc35
  kf5-sonnet-ui 5.87.0-1.fc35 -> 5.88.0-1.fc35
  qt5-qttools-common 5.15.2-7.fc35 -> 5.15.2-8.fc35
  qt5-qttools-libs-designer 5.15.2-7.fc35 -> 5.15.2-8.fc35
Changes queued for next boot. Run "systemctl reboot" to start a reboot

But then this happens:

$ rpm-ostree override remove pulseaudio-module-bluetooth --install pulseaudio-module-bluetooth-freeworld
error: Package/capability 'pulseaudio-module-bluetooth-freeworld' is already requested

Edit: And after rebooting, I see this also does not help. :sweat_smile:

The same is happening on “plain” Fedora 35 desktop.

1 Like

@copperi Do you also have aptX support/codecs installed from rpmfusion or what is the reason for you?

Now cross-posted this to Ask Fedora as I guess this is the proper support forum – I always get confused, especially as here are more Silverblue questions…