Cannot Find the Default Config File for Rofi in Fedora Sericea

Where is the default rofi configuration file in Sericia?
It is not in $XDG_CONFIG_HOME
I want to add an application that I installed as a tar.gz tarball file.
I added it to my /opt/ and added that to my $PATH.
The executable is in the extracted folder.

I added it to my $PATH in by ~/.bashrc, so I can run it from Bash. I tried adding it to my /etc/environment, but after rebooting, rofi still couldn’t run the application so i removed it. My /etc/environment did not exist so created it. When I tried to run the applicaiton and it didn’t work I deleted the /etc/environment file undoing what I had done.

The method used for installation is indicating that this is a self-compiled app.
Does not the documentation from the source give you any information? It should.

You did not even provide a link to the source you used so we are crippled in how to even test what you claim to have done and cannot review the documentation to make suggestions.

If you meant you are running Fedora Sericia then that is an immutable system and management is different than is done with a normal workstation type version. Installing 3rd party apps can be very difficult on such a system.

A quick search for ‘rofi linux’ gave me a lot of links but without knowing the exact source used it is difficult to do a test of any reasonable kind.

Rofi is installed by default.

No the application has no doccumentation. It is a web game, Tetrio. I am not compiling it; the executable is in the tarball.

This is it: DESKTOP - TETR.IO.

It is not open source (unfortunately). The tarball is the only viable install option.

Okay this is embarassing. So the problem is that I had to run it with the toolbox run command. Works in Rofi now.

This then is a typical example of an X Y problem.
Your title asks about a config file for Rofi, but the solution shows that you are trying to run