Cannot enable second monitor after disabling it

Hello everyone!

Last weekend I installed Fedora 40 on my PC, and it worked perfectly until today. I have a dual monitor setup, which was the first thing I configured when I installed the OS, I just had to change the order of the displays and that was it.

But today in the morning, I was working on my job laptop, and needed the second screen so I disabled it in the system settings via the displays menu, where I selected my second screen and clicked on the top right switch, then saved changes. I proceeded to disconnect the corresponding HDMI from my graphics card (AMD Radeon 6650 XT) and used my main PC mainly for some background music.

After I finished working, I connected my second screen again, and it didn’t display anything, which was to be expected because it was disabled. The thing is, when I go to display settings and click on the switch again, I get a popup saying “Keep these display settings? revert or keep”, then my main screen turns to black, after that both screens turn on, but no image on the second one, finally the second screen turns to black and it appears as disabled again on the settings.

One thing I tried was to disconnect my main monitor and just keep the second one connected, which worked fine (second monitor displayed everything, first one was obviously black). But when I connect the main monitor again, the issue stands.

Is this a known issue? Is there a way to bring my old setup back? maybe I have to remove some configuration file?. I can provide any further information needed to correctly diagnose the problem.

Thanks in advancement! Have a good night.

Well, I guess I asked too early, because I just solved this issue, not very elegantly thought.

The fix was to turn the second monitor off, then enable it in display settings, then turning it on and that worked. The order settings was missing though so I had to do that again. In my opinion this is still an issue, because enabling the monitor didn’t “just work”.

If anybody knows how to troubleshoot this, I’m earnest to know!

If you give us an inxi -Fzx, we might be able to help yo better, when we see what hardware you are using.

When I have 2 monitors attached and wish to use one on another system I just disconnect it and no not disable it.
When I reconnect it the original dual monitor config is restored.

This is the otuput:

System:
  Kernel: 6.8.11-300.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: GNOME v: 46.2 Distro: Fedora Linux 40 (Workstation Edition)
Machine:
  Type: Desktop Mobo: Micro-Star model: A520M-A PRO (MS-7C96) v: 1.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: 1.B0
    date: 08/11/2022
CPU:
  Info: 6-core model: AMD Ryzen 5 5600 bits: 64 type: MT MCP arch: Zen 3+
    rev: 2 cache: L1: 384 KiB L2: 3 MiB L3: 32 MiB
  Speed (MHz): avg: 2199 high: 2200 min/max: 2200/4467 boost: enabled cores:
    1: 2200 2: 2200 3: 2200 4: 2197 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200
    10: 2200 11: 2200 12: 2200 bogomips: 83997
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: AMD Navi 23 [Radeon RX 6650 XT / 6700S 6800S]
    vendor: Tul / PowerColor driver: amdgpu v: kernel arch: RDNA-2
    bus-ID: 25:00.0
  Display: wayland server: X.Org v: 24.1 with: Xwayland v: 24.1.0
    compositor: gnome-shell driver: dri: radeonsi gpu: amdgpu resolution:
    1: 1920x1080~165Hz 2: 1920x1080~60Hz
  API: OpenGL v: 4.6 vendor: amd mesa v: 24.0.9 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon RX 6650 XT (radeonsi navi23 LLVM
    18.1.6 DRM 3.57 6.8.11-300.fc40.x86_64)
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    bus-ID: 25:00.1
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 27:00.4
  Device-3: FIFINE Microphones K678 Microphone
    driver: hid-generic,snd-usb-audio,usbhid type: USB bus-ID: 3-3:4
  API: ALSA v: k6.8.11-300.fc40.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.7 status: active
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus-ID: 22:00.0
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
  IF-ID-2: vetha6ba0a9 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 26.6 GiB (2.9%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P3SSD8 size: 931.51 GiB
    temp: 25.9 C
Partition:
  ID-1: / size: 929.93 GiB used: 26.27 GiB (2.8%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 320.9 MiB (33.0%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 929.93 GiB used: 26.27 GiB (2.8%) fs: btrfs
    dev: /dev/nvme0n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 31.6 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Info:
  Memory: total: 16 GiB available: 15.53 GiB used: 2.93 GiB (18.9%)
  Processes: 398 Uptime: 1m Init: systemd target: graphical (5)
  Packages: 8 Compilers: gcc: 14.1.1 Shell: Bash v: 5.2.26 inxi: 3.3.34

Thanks!

Some monitors detect a disconnected state and turn off on their own, so they must be turned on manually when reconnected.

1 Like

Maybe also check the power-saving settings on your monitor. What kind of Monitor are you using?