Cannot disable cgroups v2 on f33?

I am trying to run k3s on Fedora 33 Server (not FCOS). k3s does not support cgroups v2 yet.

I have tried to fall back to cgroups v1 via grubby:

$ sudo grubby --update-kernel=ALL --args="systemd.unified_cgroup_hierarchy=0"

I can verify that /etc/default/grub has been updated:

$ cat /etc/default/grub 
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora_fedora/root00 rhgb quiet systemd.unified_cgroup_hierarchy=0"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true

However, after reboot and installing k3s, the service crash loops with the same errors as https://github.com/k3s-io/k3s/issues/900#issuecomment-742828865. It’s as if k3s is running with cgroups v2 anyway.

Am I missing a step to disable cgroups v2 on Fedora 33?

1 Like

I think you need to regenerate the grub config

grub2-mkconfig -o /boot/grub2/grub.cfg

Is this a regression? I rebuilt my server with Fedora 32, and the grubby command correctly disabled cgroups v2. There was no need to run grub2-mkconfig.

Not sure I always ran the grub2-mkconfig, maybe opening a bugzilla again grubby would get you more information