Cannot connect to wifi or internet with a wifi dongle from amazon

Hello so i bought a wifi dongle:

and it shows in the setting and when i click on it i dosent want to connect.

i am new to fedora 37 so i need help.

Thanks in advance

What your log files say about it ? Are there any WiFi errors ?

sorry my problem is when go into settings and then wifi it reconized the dongle but when i click on it it just loading and failed to connect to wifi

i just installed fedora like 30 minutes go and i have this problem

Still, looking into logs (e.g., via GNOME Logs app) for errors might help to understand the cause.

how can i do that?

Hit Windows/Super key, type ‘logs’ (or equivalent in your language) and choose the the Logs app. Once it is open look with search for errors, Wifi-related errors. Google errors you will find for solutions, or share it in this forum for help.
I’m assuming you installed GNOME variant of the Fedora Workstation.

So i found:rtl8xxxu 1-4:1.0 wlp0s29f7u4: renamed from wlan 0

And also now when i click on visible network in setting it does nothing

You can fetch the adapter info from the output:

lsusb -v -v -t

You should mention whether you used a legacy BIOS or UEFI install (wifi drivers may be loaded by UEFI to support network PXE booting).

This means Fedora tried to use the rtl8xxxu module:

% modinfo rtl8xxxu
filename:       /lib/modules/6.2.8-200.fc37.x86_64/kernel/drivers/net/wireless/realtek/rtl8xxxu/rtl8xxxu.ko.xz
firmware:       rtlwifi/rtl8188fufw.bin
firmware:       rtlwifi/rtl8723bu_bt.bin
firmware:       rtlwifi/rtl8723bu_nic.bin
firmware:       rtlwifi/rtl8192eu_nic.bin
firmware:       rtlwifi/rtl8192cufw_TMSC.bin
firmware:       rtlwifi/rtl8192cufw_B.bin
firmware:       rtlwifi/rtl8192cufw_A.bin
firmware:       rtlwifi/rtl8723aufw_B_NoBT.bin
firmware:       rtlwifi/rtl8723aufw_B.bin
firmware:       rtlwifi/rtl8723aufw_A.bin
license:        GPL
description:    RTL8XXXu USB mac80211 Wireless LAN Driver

One of the Amazon reviews indicates this USB dongle uses the RTL8192EU chip, but often vendors will switch chips under the same model name (especially if the model is popular!).

The rtl8xxxu driver supports 10 different realtek chips, and there are often several variants of a given chip. The firmware comes from Realtek, and it is possible yours requires recent firmware that has not made it to There should be more lines in the logs that give the exact model of your wifi device, or you can use inxi or lsusb.

Check that you have the firmware that matches your device:

 % ls /usr/lib/firmware/rtlwifi
rtl8188efw.bin.xz        rtl8192defw.bin.xz          rtl8723aufw_B.bin.xz         rtl8723bu_wowlan.bin.xz
rtl8188eufw.bin.xz       rtl8192eefw.bin.xz@         rtl8723aufw_B_NoBT.bin.xz    rtl8723defw.bin.xz
rtl8188fufw.bin.xz       rtl8192eu_ap_wowlan.bin.xz  rtl8723befw_36.bin.xz        rtl8723fw_B.bin.xz
rtl8192cfw.bin.xz        rtl8192eu_nic.bin.xz        rtl8723befw.bin.xz           rtl8723fw.bin.xz
rtl8192cfwU_B.bin.xz     rtl8192eu_wowlan.bin.xz     rtl8723bs_ap_wowlan.bin.xz@  rtl8812aefw.bin.xz
rtl8192cfwU.bin.xz       rtl8192sefw.bin.xz          rtl8723bs_bt.bin.xz          rtl8812aefw_wowlan.bin.xz
rtl8192cufw_A.bin.xz     rtl8710bufw_SMIC.bin.xz     rtl8723bs_nic.bin.xz@        rtl8821aefw_29.bin.xz
rtl8192cufw_B.bin.xz     rtl8710bufw_UMC.bin.xz      rtl8723bs_wowlan.bin.xz@     rtl8821aefw.bin.xz
rtl8192cufw.bin.xz       rtl8712u.bin.xz             rtl8723bu_ap_wowlan.bin.xz   rtl8821aefw_wowlan.bin.xz
rtl8192cufw_TMSC.bin.xz  rtl8723aufw_A.bin.xz        rtl8723bu_nic.bin.xz         rtl8822befw.bin.xz

Note that there are multiple rtl8192eu firmware files.

Simply updating your system may get more recent firmware than the installer provides.

A number of other users have recently encountered issues with rtl8192eu chips. Once you have verified that you do have this model you can read what others have done.

1 Like

Andthanks for your response so what should i do

We can’t help you without information. You can either do your own research to see what others have done to enable USB wifi in linux with the same wifi chipset or provide enough details for us to determine why it fails.

I’m guessing you don’t have internet access from the laptop, so it is difficult for your to post full details. Do you have internet access using the Fedora Live USB image (or some other distro)?
Have you tried booting with the wifi key attached and also booting without it and then plugging it in? If the Fedora Live Image supports your USB wifi, you should have wifi using the rescue kernel (pressing the key when linux starts to boot should give a list of kernels).

You could try USB tetheriing. You can compose a detailed response and transfer the file using a USB key to a system with network access.

If you can get internet access you can generate a detailed summary of your hardware, submit it to
the linux-hardware site, and post the ID here so we can see the full ID of the USB wifi key.

  1. provide the adapter information from:
  1. [quote=“George N. White III, post:11, topic:80327, username:gnwiii”]
    mention whether you used legacy BIOS or UEFI install

  2. You provided one line from the logs. There should be many more lines that could tell us why the device isn’t working.