Cannot connect to Ca’ Foscari University of Venice’s eduroam wifi

I cannot connect to my university’s eduroam network. I am 100% sure credentials are correct. Here is the configuration I am using ( would upload a screenshot but I get a prompt saying something went wrong while uploading the screenshots):

  • PEAP authentication
  • “no digital certificate required” checked
  • Auto PEAP version
  • Inner authentication: MSCHAPv2
  • my university’s account’s username and password

The connection loads, but then it times out, re-prompting me with password and username.

Even after running the script downloaded from cat.eduroam.org, the problem persists.

I am running Fedora 38 with kernel 6.3.3 (issue has been occurring also with 6.1 and 6.2).

Do you have any suggestions?

It’s hard to tell from that info.
In any case, I use MSCHAPv2(noEAP) with Eduroam. But you should also double check how you are supposed to specify your username for eduroam - it includes the radius realm.

1 Like

Hello @xplosionmind, have you seen this post? Cannot connect to WPA2-Enterprise University wifi (Eduroam) on Fedora 36+
Or maybe these other ones
Search results for 'eduroam' - Fedora Discussion

3 Likes

Hi! Thanks for your reply!

I checked any other eduroam-related post. Solutions are obsolete or not working.

Can you provide your system logs please so we can get some idea of what may not be working? Eduroam works fine for me here at my university with the fix Alessio noted.

As you see in the post Alessio noted, wpa_supplicant related logs are probably ones to start at.

My uni needs a special certificate to work.

They dont have this script, seems that this is actually quite nice.

Try importing that license manually

1 Like

Hi @xplosionmind! Same issue here… (with Ca’ Foscari and other universities too).
Did you find any working solution? Thanks a lot :slight_smile:

I am running Fedora 39
I added the network via the https://cat.eduroam.org/ python script

Both adding

[ crypto_policy ]

Options = UnsafeLegacyRenegotiation

in /etc/pki/tls/openssl.cnf

and running

sudo update-crypto-policies --set DEFAULT:FEDORA32 

or

sudo update-crypto-policies --set LEGACY

did not fix it for me.

I remember seeing this on reddit shortly after the F39 release… eduroam connection fix · GitHub

The short version is:

nmcli con mod id <your connection name> 802-1x.phase1-auth-flags 32
5 Likes

Maybe we need a Common Issues entry for this?

3 Likes

Amazing!! It worked like a charm :heart_eyes:
Thank you very much, really appreciated. I hope to be able to give back to the community at the earliest occasion :fedora:

4 Likes