Cannot browse Windows shares on network (smbc_opendir: No such file or directory)

Hey, I needed to send a file to a Windows machine on my local network and realised that Samba is not working on my system. I remembered it giving an error in Files for a long time but always shrugged it off.

Can anyone reproduce this? (Same error in Nautilus. Tried in a clean system too.)

$ smbtree
smbc_opendir: No such file or directory

I’ve given it half an hour of research but found nothing. Maybe it’s Silverblue-specific?

Can still reproduce on Silverblue 34. The firewall is disabled, but it doesn’t work with an enabled one in a clean system either.

Windows file share got lots of changes in past years.

Even between Win10 machine, it can be tricky to make file sharing between them work (for me).

When I run smbtree, I get no output at all. I do have an OMV server on the network with a couple shares, but it is not detecting them. But I do see the shares when using Files though.

Check to make sure cifs-utils is installed. That was my issue.

I already have them installed; you didn’t?

$ rpm-ostree install cifs-utils
error: "cifs-utils" is already provided by: cifs-utils-6.11-3.fc34.x86_64. Use --allow-inactive to explicitly require it.