Can’t setup fingerprint

I use Silverblue on a Thinkpad X220, but I noticed that, in contrast to Fedora, I can’t setup my fingerprint reader. Am I missing a package? If so, why isn’t it installed by default? Cheers.

So, i suspect the first missing package might be fprintd. It is not installed on my laptop, but that’s core to having fingerprint working. I would suggest to start here and see how it go. I can’t do much testing since my laptop with a fingerprint reader is not the one with silverblue.

Yeah, tried fprint and it worked! Though I have some issues logging in with it, but it was always a bit buggy…

sounds like we need to get that package included in the comps for workstation. Who can help make that happen?

Hm, though I celebrated too soon… I can set up my fingerprint, but I can’t log in/unlock with it.

Yeah, I still can’t actually use the fingerprint… any idea what might be wrong? Maybe a config change is needed or something?

Turns out you need fprint-pam too for it to work. :slightly_smiling_face:

So, could you please include fprint fprint-pam into the base image? This is basic functionality really.

1 Like

So after you get fprint and fprint-pam installed, what are the next steps to get your fingerprints enrolled in the login configuration?

Just set it in GNOME Settings under Accounts.