Can someone please assist me in installing a printer

Dear Fedora Community,

Not sure if anyone can help.

I just moved from Fedora 31 from windows. Since 1998 I have been a windows user.

Fedora is incredible cannot believe how my hardware functions now.

Can someone please assist me in installing the printers.

Please assist any help would be really appreciated.


you could do it in several ways.

sudo dnf install system-config-printer

if you use Gnome
Gnome-System-Setting ( top most right screen icon => “the wheel there in the popup, left from powerdown” => “Devices” => “Printer” => “unlock” => “Add”

in your web-browser: http://localhost:631/

the last two are preferred !

If your printer is supported, see:


Check out the documentation:

Also try to avoid mDNS/Bonjour discovery in favor of AppSocket/JetDirect, IPP or LPD.
Search for PPD driver manually if required.

1 Like

You can see in the post under some pictures what mates did point.


1 Like


I get this message actually.

find attached


Thanks for the post

Actually I try the CUPS method but I cannot login. I tried my username from this computer but it doesnt work

Huh, here I’m don’t need to provide any username or password.
baffling !


if I add a printer I’m ask to provide a username/password.
In my case it is my username and my password !

I did that last time several month/years ago, so I forgot about it, sorry

I can’t find a packages named brscan4 here in the official repo’s !

where do you got it from ?

Did you try to log in as root?
Set the password beforehand if required.

Google points to
I suggest to install it via terminal to see the errors if any.

yup, I googled it already, anyway: thanks !
and tried to installed it.
it went without errors !


I did it this way in an terminal after downloading the package and cd’ing in the download dir :

sudo dnf localinstall ./brscan4-0.4.2-1.x86_64.rpm

downlaod was from here:

1 Like


could you please provide the name and the exact typ of your printer ?

Yes I have two.

One is a Brother MFC-7362N. I need the scanner to work also.

The other is a Brother HL-2140

Thanks so much I really appreciate your help. I am really loving this Fedora 31 I am using as I have been using Windows 7 for 8 years

[benji@benji ~]$ sudo su
[sudo] password for benji:
[root@benji benji]# sudo dnf localinstall ./brscan4-0.4.2-1.x86_64.rpm
Fedora 31 openh264 (From Cisco) - x86_64 176 B/s | 543 B 00:03
Fedora Modular 31 - x86_64 17 kB/s | 37 kB 00:02
Fedora Modular 31 - x86_64 - Updates 2.5 kB/s | 2.9 kB 00:01
Fedora 31 - x86_64 - Updates 3.9 kB/s | 3.8 kB 00:00
Fedora 31 - x86_64 - Updates 1.9 MB/s | 6.0 MB 00:03
Fedora 31 - x86_64 27 kB/s | 37 kB 00:01
Opera packages 5.8 kB/s | 2.9 kB 00:00
Opera packages 6.5 kB/s | 11 kB 00:01
RPM Fusion for Fedora 31 - Free - Updates 5.5 kB/s | 14 kB 00:02
RPM Fusion for Fedora 31 - Free - Updates 15 kB/s | 41 kB 00:02
RPM Fusion for Fedora 31 - Free 7.2 kB/s | 15 kB 00:02
RPM Fusion for Fedora 31 - Nonfree - Updates 6.3 kB/s | 14 kB 00:02
RPM Fusion for Fedora 31 - Nonfree - Updates 2.3 kB/s | 5.3 kB 00:02
RPM Fusion for Fedora 31 - Nonfree 6.1 kB/s | 15 kB 00:02
skype (stable) 1.6 kB/s | 2.9 kB 00:01
Can not load RPM file: ./brscan4-0.4.2-1.x86_64.rpm.
Could not open: ./brscan4-0.4.2-1.x86_64.rpm
[root@benji benji]#

you need to do

sudo -s

to get root access until you log out from terminal.
so you could then do only:

dnf localinstall ./brscan4-0.4.2-1.x86_64.rpm

without leading “sudo”.
the dnf command will only work if you changed to the directory where you downloaded the packages:


usually ~/Downloads ( “~” is a short form of /home/<your-username>)
and only if the whole package name is correct !

for a correct package name you could do the following:
type in only:

dnf localinstall ./brsca

and then hit the tab key (left from the “q” key).
it will expand “brsca” to the full name (I believe it’s called “command expansion” or the like, see in an terminal: man bash (the linux manual on the box or read it in the internet too)
I support the “command expansion” somewhat with providing “./” in front of the package name. It shall “search” only in the current directory, which is in Linux/Unix the point (".").

often (ever ?) “command expansion” works with command parameter too, so
dnf lo <Tab-Key> expands first to “local” and a next <Tab-Key> gives two chances “localinstall” or “localupdate”. I need to key in only the “i” and hit the <Tab-Key> again to expand to “localinstall” !
Advantage are an error free command line and less typing work.

but back to the topic:
“HL-2140” should work if you configured it first (see above)
difficulty may come up with the “MFC-7362N”

  • the printer driver is NOT in the printer openprinting database
  • the scanner driver may work, if the driver you’re trying to install will work, cause it seems there is NO official support too, see:

I guess you need to try to get info’s to get it running from vendor support foren or google.

maybe an option is to get the printer running in an virtual machine or an old notebook running windows 7 and share the printer via local network. - just a wild guess by me before putting the printer complete offline… -

maybe you get luck with the vendor driver, don’t know !

1 Like

Hi again and thank you so much for your help.

I have decided to give up on the scanner. I tried very hard and its really frustrating as I need the scanner for work. I am kind of regretting moving to Fedora from windows 7 but i want to persist as I detest windows 10.

Fedora runs beautifully on my system but I have some problems.

1- The CPU cooler fan stays on full blast after it wakes up after sleep.
2- printer and scanner drivers dont work.
3- I need the Zoom app to work with better volume

I use this laptop for work and I am willing to pay anyone who can help. Can someone assist from this chat or one of the Fedora Engineers. I can setup Team viewer maybe or something so I can get it reconfigured,

As I said:
setup a windows 7 in an virtual box.
more to read:

you just start windows like an app under fedora.
run scanner/printer and all the app you need in the windows.
share the printer/scanner via local network.
and you are done

Team viewer:
there is another app for remote administration:

  • ~5 MB versus ~80 MB
  • quicker

thanks for your help and patience. I think I can configure the printer to work with some more patience. Could you help me work out why my CPU cooler fan stays on full blast when it wakes up after sleep? or who I could get to help?

I have a dual boot setup on my other PC which will solve the problem of the other printer. I have had success today installing the scanner drivers and they work on POP_OS which is great. I will try the same process with Fedora OS today. And I will try reading the help centre on Fedora too thanks a lot for your help

1 Like

Maybe I am a bit late to the party, but brother printers have a very simple but not too intuitive installation procedure.
You need the brother printer install script rpm to add a brother printer
First go to the brother support sit: Others | Brother support website
Then find your printer
For me it is the DCP-J132W
Find in Utilities the driver install tool and download it.
The tool will install LPR, CUPSwrapper driver and scanner driver (for scanner models).
Agree with the EULA and download the tool. It is in tar.gz format
In the next page it will say how to use the tool:

#How to Install

Step1. Download the tool.(linux-brprinter-installer-*.*.*-*.gz)

The tool will be downloaded into the default "Download" directory.
(The directory location varies depending on your Linux distribution.)
e.g. /home/(LoginName)/Download

Step2. Open a terminal window.

Step3. Go to the directory you downloaded the file to in the last step. By using the cd command.

e.g. cd Downloads

Step4. Enter this command to extract the downloaded file:

**Command: gunzip linux-brprinter-installer-*.*.*-*.gz**

e.g. gunzip linux-brprinter-installer-2.1.1-1.gz

Step5. Get superuser authorization with the " **su** " command or " **sudo su** " command.

Step6. Run the tool:

**Command: bash linux-brprinter-installer-*.*.*-* Brother machine name**
e.g. bash linux-brprinter-installer-2.1.1-1 MFC-J880DW

Step7. The driver installation will start. Follow the installation screen directions.

When you see the message “Will you specify the DeviceURI ?”,

For USB Users: Choose N(No)
For Network Users: Choose Y(Yes) and DeviceURI number.

The install process may take some time. Please wait until it is complete.

1 Like

thanks a lot, i will try that,

I would like to change my operating system for our business to the fedora 33 system.

At present I am running the debian based pop OS 20.04.

My concern is whether i will be having any issues with the video card. I tried to install fedora 29 and fedora 30 many times and had my system freeze up.

how can I install fedora with the nvidia drivers ?