Camera not working Fedora 36 Lenovo Yoga 6

Hello. The camera doesn’t work in any communications app, Teams, Zoom, etc. The icon is grayed out, and it shows in the settings as if there’s no problem. It worked before, but can’t tell after which update it stopped. Everything else seems to work. Any solutions?

You only need one of the dnf update or dnf upgrade commands. Chaining them like this repeats the same command with the second one.

1 Like

@geplinux Please remain friendly and excellent to each other. This is how our community works, and it is the best way to ensure appropriate communication and knowledge transfer. Also, please avoid double postings like those above.

Assuming that you just wanted to joke, you should be a bit careful as your two posts above can be easily misunderstood. Things like irony or sarcasm can be funny in person but are dangerous in a written form on multilingual forums with many non-natives. Therefore, this should be avoided here.

Thanks for your contribtion to ask.:fedora: & see you in future threads!

1 Like

Doing the command twice is certainly your right and it does not hurt things for you.

What it may easily do for newbies is to confuse them since it is 1) not necessary and 2) may possibly be even more confusing for those who may have come from a debian based distro where apt does require the update command followed by the upgrade command.

What I really am looking at is recommending the minimal commands necessary to simplify things and not overwhelm new users or add additional things that may be misinterpreted as needed when they are totally unnecessary. KISS.

As far as the camera goes, there are several things I can suggest to follow on with what has already been said.

  1. post the output of inxi -Fzx, lspci, and lsusb so we can see if the system is recognizing and configuring the camera. The camera will need to be attached if it is connected by USB.
  2. If the camera is USB attached then also run dmesg | tail 50 immediately after attaching the camera and post the result so we can see what the kernel says about the camera.

Once we know the system sees and configures the camera then we can look at why specific apps are not able to use it.

I tried all the apps with webcam in Fedora, tried Mint on a usb, and devolved the pc to Windows, same problem with the camera. So, of course it was hardware. And in a primitive way. Takeaway: If you ever have no choice but to use electrical tape to cover the camera, wash the hell out of it -not just wipe, I mean, use soap and repeated passes, even if it looks clean. The image came back gradually. And of course I feel silly --putting this last note for atonement

1 Like

Thank you for sharing this. The resolution used can sometimes be a problem and changing it is often one of the trouble shooting steps.

Again, thanks.

Please Jeff V I need your help now !
How to delete my account and all my posts
You can do that for me ? Please
Just wanted to help … Not angry just tired, don’t worry…

I don’t think deleting an account and posts is possible. It is possible though to ask a moderator to anonimize your account if that is truly what you wish. You will have to take that step if you wish.

Please post your request in the #site-feedback category and an admin will take care of it.

PS: in general using bold text implies shouting/screaming on the internet (chat/forums/wherever), so this should be used very sparingly.

Thanks for for help I will ask to the link in bold…