Camera not detected by system

This seems like a little odd one. Fresh install of Silverblue, the laptop built in camera is not detected and cannot be used in Cheese. However, Chromium based web browsers can see and use it just fine with no messing with it. Is there some hidden setting I’m not seeing? Privacy says that no applications have requested access to the camera.

Hey and welcome @nreynolds !

Glad you are on Silverblue! That’s a bit odd indeed bc I have installed Cheese and my camera is working oob.
Have u checked probably missing drivers?



How would I go about checking for this? The way Silverblue works is VERY different from any Linux distro I’ve ever used. Coming from years of Ubuntu/Mint use and then a year or so of Arch.

One thing you can do, if u didn’t do this

rpm-ostree upgrade → for first upgrade your OS



Thanks for the link. Yes, the first thing I did was rpm-ostree upgrade because the software center was telling me my OS was no longer supported. Found that this is a bug and once you upgrade through CLI, it works just fine.

okay great! :slight_smile:

lol! Just to be clear, the software center works fine. The camera is still no go. Out of curiosity, I plugged in a USB web cam and the same thing but lsusb sees it. I don’t know how the internal camera is connected, though.

Through a chromium web browser, I can see both cameras and switch back and forth no problem.

What the hell :smiley:

I have installed Cheese via Flatpak and checked for me that is is working. But it’s really curious that your USB webcam has the same odd issues.

Is the Chromium browser layered or a flatpak? Perhaps if Cheese is a flatpak you should install Flatseal to check if it is getting the correct access to the hardware.

They’re both flatpak. I believe cheese is installed from Fedora and brave installed from flathub because it’s not in Fedora. I’ll give flatseal a shot since I’ve never messed with it and it would probably be a good tool to learn.

Well at the very least it will allow you to compare the permissions.

1 Like

Ok, compared permissions and it had access to hardware. Out of curiosity, I uninstalled Fedora version and installed from flathub. Cheese works now so who knows what the issue is with the Fedora version.

1 Like

Well. sry that I have forgotten to say yesterday that u should test the Flatpak version :slight_smile:

I just tested it. There is definitely a bug in the Fedora Flatpak version of Cheese, as it doesn’t detect my webcam. Cheese from Flathub instead works.

EDIT: apparently there’s a bug report about this open since last December: 2035106 – Cheese Flatpak is missing camera permissions

1 Like