Bug report: Splitting a thread with a solution makes it impossible to remove the solution flag

Hi @mattdm , I have a bug report. I moved all the posts from this common issue to this talk topic. But I haven’t noticed that one of the posts was already marked as a solution to the common issue. After the move, the common issue is still considered to be solved, and I can’t mark any other post as a solution (I’d like to mark this one). I went to the talk topic and unmarked the moved “solution” post, but that didn’t help, the common issue is still stuck in the solved status.

I think this is clearly a bug. When moving posts to elsewhere, the solution flag should be probably removed (that seems most logical), but isn’t. There seems to be no way to fix the situation from my side. Can you report this bug to Discourse (or should I report this to them directly next time?). Thanks!

I was able and mark your post as solution. Could it be a permission (trust level) issue?

Huh, that’s really interesting. I tried to unmark that solution flag, and now I can mark it back. I… don’t know, I’m starting to question my sanity :slight_smile: Hmmm. So I guess let’s wait if it happens again, and I’ll be paying really close attention next time.

1 Like

maybe @mattdm should promote you to a higher TL so you can do stuff like that in the future.

Well I usually can. It was just this particular instance when I think it was bugged out because of moving the posts. Or I was being blind. We’ll see next time.