Bug in Firefox 104 causes crash, Fix is in Firefox 106

Hello to you,

I tried to start Firefox this morning and it repeated crashed during startup.
Firefox even crashes in safe mode.

firefox --safe-mode

Searching the journal revealed:

Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs

The log messages from the journal show that is the last message from firefox before it crashes.

$ journalctl -b -0 | grep -A 2 firefox
Sep 23 06:19:08 example.com firefox.desktop[4964]: Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs
Sep 23 06:19:09 example.com audit[5214]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=3 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=5214 comm="WebExtensions" exe="/usr/lib64/firefox/firefox" sig=11 res=1

Searching bug reports shows this is a know issue which was fixed but only in Firefox 106.

Is there any way to install Firefox 106 on Fedora 36?


Are you using the rpm or something else, e.g. Mozilla’s binary, a flatpak or snap?
With firefox-104.0.2-1.fc36 I see that error message, but Firefox is rock-solid.

If you really want to run v106, you can try one of the COPRs that carry it, or use the nightly build from Mozilla.


Thanks, I forgot about COPR.

$ rpm -q firefox

Funny thing is my last Firefox update was on September 17, 2022 but the bug didn’t start until today (September 23, 2022).

2022-09-17T08:07:34-0400 SUBDEBUG Upgrade: firefox-104.0.2-1.fc36.x86_64
2022-09-17T08:07:36-0400 SUBDEBUG Upgraded: firefox-104.0.1-1.fc36.x86_64

In that case, it may be worth checking if it’s not a red herring, following the instructions here. If you do pinpoint another issue, you should file a bug.

1 Like

There is a possibility that it’s due to changes in the net gear on my LAN. My Marvell Clearfog Pro running Arch Linux Arm bit the dust on a software update. In general 32-bit support for Linux is dying and it’s an armv7. I had to switch to my backup router. The Clearfog Pro was running Pi-Hole directly on the router on bare metal. My backup router is running OpenWRT and it doesn’t have enough RAM to run Pi-Hole so I’m now running Pi-Hole in a podman container on a laptop on a shelf with the case closed (“mini-server”). I have to go out and buy new network cables to get the router off of the floor. It’s been rough because I have so many projects including switching to a new Google Pixel 6a. On top of everything I got my fourth COVID vaccination (Moderna bivalent) two days ago and it was a doozy.

I always get that message whether firefox chrashes or not. And as far as I remeber, for the past many releases.

If Pi-Hole is somehow interfering with the remnants of the Firefox updater, it might be the case. You could very easily (???) connect directly to your router and see if you still get the crashes.

In any case, thank you so much for the photo, it made my day :rofl:

Oh dear,

$ rpm -qV firefox
..5......    /usr/lib64/firefox/libxul.so

It’s alive again. i just copied that shlib from another system rather than suffer through reinstallation.