Brother Printer No longer working since recent update

Hi there,

A strange thing has happened where the scanner remains to work although the printer is not communicating to the computer. Since the recent kernel upgrade this has happened.

Could any please assist. I would like to try to uninstall the driver and reinstall.

System details below

OS: Fedora Linux 35 (Workstation Editi 
Kernel: 5.15.11-200.fc35.x86_64 
Shell: bash 5.1.8 
DE: GNOME 41.2 
WM: Mutter 
WM Theme: Adwaita 
Theme: Adwaita-dark [GTK2/3] 
Icons: Adwaita [GTK2/3] 
Terminal: gnome-terminal 
CPU: Intel i5-3570K (4) @ 3.800GHz 
GPU: AMD ATI Radeon RX 470/480/570/570 
Memory: 5031MiB / 15938MiB 

Printer details below                                                             

device for MFC7362N: usb://Brother/MFC-7362N?serial=E69897F3N592246
MFC-7362N accepting requests since Sat 01 Jan 2022 07:20:12 AEDT
MFC7362N accepting requests since Sat 01 Jan 2022 06:31:38 AEDT
printer MFC-7362N is idle.  enabled since Sat 01 Jan 2022 07:20:12 AEDT
printer MFC7362N is idle.  enabled since Sat 01 Jan 2022 06:31:38 AEDT
	Sending data to printer.
MFC7362N-182            anonymous         1024   Sat 01 Jan 2022 06:31:35 AEDT
MFC7362N-183            anonymous         1024   Sat 01 Jan 2022 06:31:38 AEDT
[solomon@fedora ~]$ lpinfo -v
network beh
file cups-brf:/
serial serial:/dev/ttyS0?baud=115200
network ipp
network ipps
network http
network lpd
network socket
network https
direct hp
direct usb://Brother/MFC-7362N?serial=E69897F3N592246
network smb
direct hpfax
[solomon@fedora ~]$ driverless

It looks like you may have duplicate entries for that printer and thus may have conflicts for communication. In fact it is seen as MFC-7362N and also as MFC7362N.

I would suggest you disconnect the printer, use cups or your settings control panel to remove all printer configs, then reconnect the printer and see if it then will properly reconfigure and work.

thanks for you help. :slight_smile:

yes I have two because I tried to add it again thinking it wasn’t configured properly after the update.

I tried what you mentioned earlier to no success unfortunately.

I powered off the printer. removed the cable, then I went to this domain again just now


removed both printers. No printers in the list.

Then I went plugged back in the printer, powered it up and it reinstalled the printer in the menu.

Tried a test page and no response.

I did run the “driverless” command by accident in the terminal 2 weeks back. Could that have messed up with the drivers somehow?