Brother network scanner DCP-540CN not recognized

The Brother driver install tool usually does output diagnostic info or log it during install.

Does it bemoan anything?

I’ve run the driver install tool again and recognized the following output which might give a hint:

You are going to install following packages.
rpm -ihv --nodeps --replacefiles --replacepkgs brscan2-0.2.5-1.x86_64.rpm
Verifying...                          ################################# [100%]
Preparing...                          ################################# [100%]
Updating / installing...
   1:brscan2-0.2.5-1                  ################################# [100%]
/sbin/ldconfig: /lib/ is not a symbolic link

/sbin/ldconfig: /lib/ is not a symbolic link

Well, the mentioned files are instead ELF 64-bit binaries:

$ ls -l /lib/{,} && file /lib/{,}
-rwxr-xr-x. 1 root root 15072 24. Mai 13:33 /lib/
-rwxr-xr-x. 1 root root 37064 24. Mai 13:33 /lib/
/lib/    ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
/lib/ ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

There were no other error messages or warnings.

u could always



ln -s …

to satisfy Brother … then revert if unsuccessful

I’m quite OK with my Bro and wrote a guide on Debian wiki for it.

Creating symlinks didn’t do the trick.

Could you link to your debian guide, please? I would like to adapt it for my installation.

I remembered that in the past I had to copy/link files from /usr/lib64/sane/libsane-brother* to /usr/lib/. So I did:

# find /usr/lib64/sane/ -type f -name "libsane-brother*"
# ln -s /usr/lib64/sane/ /usr/lib/

But no success so far. Maybe I’m still missing some packages but I don’ know which it could be. Here is a list of installed an available sane-related packages on my system:

Installed Packages
sane-airscan.x86_64                            0.99.26-1.fc34          @updates 
sane-backends.x86_64                           1.0.32-4.fc34           @anaconda
sane-backends-drivers-cameras.x86_64           1.0.32-4.fc34           @anaconda
sane-backends-drivers-scanners.x86_64          1.0.32-4.fc34           @anaconda
sane-backends-libs.x86_64                      1.0.32-4.fc34           @anaconda
Available Packages
sane-backends-daemon.x86_64                    1.0.32-4.fc34           fedora   
sane-backends-devel.i686                       1.0.32-4.fc34           fedora   
sane-backends-devel.x86_64                     1.0.32-4.fc34           fedora   
sane-backends-doc.noarch                       1.0.32-4.fc34           fedora   
sane-backends-drivers-cameras.i686             1.0.32-4.fc34           fedora   
sane-backends-drivers-scanners.i686            1.0.32-4.fc34           fedora   
sane-backends-libs.i686                        1.0.32-4.fc34           fedora   
sane-frontends.x86_64                          1.0.14-39.fc34          fedora

Any idea what to try next?


Thank you very much for the link.

I copied the mentioned libs from /usr/lib64/* to the according place in /usr/lib/*. No success so far.

But I noticed that there are no saned user or group nor a group scanner present on my host. I would have guessed these groups should exist, shouldn’t they? I couldn’t figure out which packages are providing these user and groups. Does somebody know how to get this info?

I ran a package capture to see what happens on the wire (or in the air in case of WLAN), when starting xsane or simple-scan. And there has not a single package been sent to the IP address of my DCP-540CN.

Since no packet is leaving my host I guess the issue is located on my local system. Any ideas what I might have missed?

1 Like

tbh, my Brother model had only issues that were easy to spot and fix, such as some .cpp source bug.

your model I have no experience with especially on Fedo.

yes such little things should be fixed by the packager but they usually show as error in journald

with your model it seems the driver does not work at all. hmmm

encouraging. maybe still dig into journald , or try an installation quickly in a Debian Live-CDROM for comparison and to familiarize oneself with the Brother driver et cetera.

Looking at the list of sane related packages I do not see “sane” or “xsane” in your list. I checked mine and I find this

# dnf list installed '*sane*'
Installed Packages
libsane-airscan.x86_64                                                   0.99.26-1.fc33                                     @updates
libsane-hpaio.x86_64                                                     3.21.2-2.fc33                                      @updates
sane-airscan.x86_64                                                      0.99.26-1.fc33                                     @updates
sane-backends.x86_64                                                     1.0.32-4.fc33                                      @updates
sane-backends-drivers-cameras.x86_64                                     1.0.32-4.fc33                                      @updates
sane-backends-drivers-scanners.x86_64                                    1.0.32-4.fc33                                      @updates
sane-backends-libs.x86_64                                                1.0.32-4.fc33                                      @updates
xsane.x86_64                                                             0.999-37.fc33                                      @fedora 
xsane-common.x86_64                                                      0.999-37.fc33                                      @fedora 

While mine is an HP and not a Brother, the only part specific to the brand is the libsane-hpaio. Possibly that could be the issue for you if sane has a brother specific package.

Another thing that may be related is the way it was configured.

  1. The printer should be assigned a fixed IP that will never change. Relying on DHCP to keep the address the same forever is asking for problems. You can either assign it on the scanner or assign it as reserved on the DHCP server.
  2. When configuring it on the PC you should specify its IP address so there is no confusion when PC records the connection URL.

I never did anything specific to configure the scanner other than install the proprietary driver for the scanner when the printer was configured. Once the printer was properly configured so cups saw it, sane was able to access it as well. Without the driver sane fails. I have never had a connection problem with my hpaio printer printing or scanning since I started using fixed IPs for it.

Hi, I ran sudo journalctl -f -p debug and started xsane afterwards. And there was not a single line in Journal appearing. So I booted the latest Debian Testing Live Image and installed the drivers and it works out-of-the-box without further steps.

I have to think about it.

Hi JV,
Thank you for joining this topic. I used other wildcards to filter the package list. I’ve just checked and confirm that I have installed the same packages as you.

The IP address of my device is configured fixed at the device. And I use the IP address as the connection URI in brsaneconfig2.

I’m aware that the DCP-540CN is a pretty old model. I have it since 2006. So I’d guess nobody else around here has such a nice piece of hardware in use. But it’s still working fine and the ink is cheaper then ever before. So I’d like to use it until it reaches the end of it’s ultimate life-cycle.

1 Like

if that DCP has USB, by all means plug that in too.

It appears you don’t have sane-frontends and sane-backends-libs installed. That should allow you to test with sane-find-scanner and scanimage.

Best regards,

Here is the list of the currently installed ‘sane’ packages:

$ sudo dnf list installed '*sane*'
Installed Packages
libsane-airscan.x86_64                         0.99.26-1.fc34          @updates 
libsane-hpaio.x86_64                           3.21.2-2.fc34           @updates 
sane-airscan.x86_64                            0.99.26-1.fc34          @updates 
sane-backends.x86_64                           1.0.32-4.fc34           @fedora  
sane-backends-devel.x86_64                     1.0.32-4.fc34           @fedora  
sane-backends-doc.noarch                       1.0.32-4.fc34           @fedora  
sane-backends-drivers-cameras.x86_64           1.0.32-4.fc34           @anaconda
sane-backends-drivers-scanners.x86_64          1.0.32-4.fc34           @fedora  
sane-backends-libs.x86_64                      1.0.32-4.fc34           @fedora  
sane-frontends.x86_64                          1.0.14-39.fc34          @fedora  
xsane.x86_64                                   0.999-40.fc34           @fedora  
xsane-common.x86_64                            0.999-40.fc34           @fedora

Since brsaneconfig2 is able to ping my scanner I guess the problem is somewhere in between. As mentioned above my system is missing the groups ‘sane’ and ‘scanner’ which seem to exist on Debian based systems. I’m not quite sure if this is an issue here.

I assume that brconfigsane2 is a command installed with the brother driver. I don’t have it (no brother devices).

I doubt those two groups have an affect. I don’t have them and my scanner works well with no trouble accessing it.

Have you tried “sane-find-scanner” or “scanimage -L” to see if the scanner is actually identified. Using sane-find-scanner won’t reveal a network scanner, but the latter was able to see even my wifi connected scanner as you can see.

# scanimage -L
device `hpaio:/net/HP_Color_LaserJet_MFP_M277dw?ip=' is a Hewlett-Packard HP_Color_LaserJet_MFP_M277dw all-in-one

Yes, brsaneconfig2 was installed by the scanner driver. It’s a CLI tool used to configure network scanners and tests the network connection to it. In my initial post you could see that this works just fine.

The sane-find-scanner tool didn’t find any network scanner. But I believe it isn’t capable to do so at all. scanimage -L only finds my integrated webcam and another scanner on network, but not the DCP-540CN.

$ scanimage -L
device `v4l:/dev/video2' is a Noname Integrated Camera: Integrated I virtual device
device `v4l:/dev/video0' is a Noname Integrated Camera: Integrated C virtual device
device `airscan:e0:Brother MFC-J890DW' is a eSCL Brother MFC-J890DW ip=

I’m just curious why I couldn’t get the DCP-540CN to work on network. But maybe it’s just too old and the driver doesn’t work correctly.


on my brother MFC I can scan paper onto my Android via ftp all over WLAN. pretty cool !