Brightness service doesn't start in Fedora Silverblue 35

I had installed fedora silverblue and everytime I logged in, my brightness would always be set to max. Both my keyboard and my screen brightness. I did a little digging and found this.

I don’t know why, but this has been the case for every boot, and since I’m new to this immutable OS distro, I don’t know exactly how to fix this.

1 Like

I’m seeing this same issue, but I hadn’t had a chance to dig into it. Thanks for pointing out that service failure, @dr0hith!

It does look like Silverblue has something set to read-only that the systemd-backlight service needs to write to. I don’t know if the fix would be as simple as setting that to rw long enough to set it and then back to ro, or if it’s something bigger where really systemd-backlight needs to be writing that information somewhere else.

Can anyone chime in as to whether a bug would be most appropriately filed against systemd or something else? I haven’t looked in a while: Is there a Silverblue component to file against?

EDIT: Restarting the service seems to have been successful. I wonder if the solution is that this service needs to wait for something else to finish before loading at boot.

EDIT 2: Actually, the service appears to have started successfully after a reboot. My brightness was restored during boot, and the service is “active”. So it looks like doing the following once may have been enough to fix it, but that’s still less than ideal for new users:

sudo systemctl restart systemd-backlight@backlight\:intel_backlight.service

Oddly enough, that solved it for me as well, lol. Thanks! But yea, it ain’t ideal. Idk how to recreate it, but peeps should be able to find this thread, if they face the same.

This worked for me, thanks.