Brightness broken and acting very strange

msut’ve gone through about 30 more entries.

ran systemctl status systemd-backlight@backlight.service
and got

 Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static)
     Active: failed (Result: exit-code) since Tue 2022-11-01 23:41:58 EET; 33s ago
       Docs: man:systemd-backlight@.service(8)
    Process: 5486 ExecStart=/usr/lib/systemd/systemd-backlight load backlight (code=exited, status=1/FAILURE)
   Main PID: 5486 (code=exited, status=1/FAILURE)
        CPU: 3ms

Nov 01 23:41:58 fedora systemd[1]: Starting systemd-backlight@backlight.service - Load/Save Screen Backlight Brightness of backlight...
Nov 01 23:41:58 fedora systemd-backlight[5486]: Requires a subsystem and sysname pair specifying a backlight device.
Nov 01 23:41:58 fedora systemd[1]: systemd-backlight@backlight.service: Main process exited, code=exited, status=1/FAILURE
Nov 01 23:41:58 fedora systemd[1]: systemd-backlight@backlight.service: Failed with result 'exit-code'.
Nov 01 23:41:58 fedora systemd[1]: Failed to start systemd-backlight@backlight.service - Load/Save Screen Backlight Brightness of backlight.
~

which can be caused by a configuring issue so here’s my etc/default/grub.

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau 
modprobe.blacklist=nouveau nvidia-drm.modeset=1 
rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau 
nvidia-drm.modeset=1 amdgpu.backlight=0"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true

IDk why cmdline is so long. My dumbass spent 5 hours today trying to figure this out please help.

After doing a bit more digging, and looking at systemctl output I found

# systemctl status systemd-backlight@backlight.service
○ systemd-backlight@backlight.service - Load/Save Screen Backlight Brightness of backlight
     Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static)
     Active: inactive (dead)
       Docs: man:systemd-backlight@.service(8)

and the man page referenced in the Docs line there led me to find

# ls /var/lib/systemd/backlight
pci-0000:00:02.0:backlight:intel_backlight  pci-0000:00:14.0-usb-0:8:1.2:leds:asus::kbd_backlight

# cat /var/lib/systemd/backlight/pci-0000:00:02.0:backlight:intel_backlight
12595

which is the value that should be saved during shutdown and restored during startup/login. The /sys filesystem is after all a tmpfs and disappears when shutdown so systemd saves the value to disk.

That command line is long because the system needs it to be so. It also shows on my screen as 4 separate lines. Please do not alter anything you copy and paste so we can see it exactly as you see it.
I think it probably showed like this when you copied it.

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 amdgpu.backlight=0"

The fact that this rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 appears twice shows you installed the nvidia drivers twice. The second copy of that may be deleted.

Why is this amdgpu.backlight=0 appearing there? You are having problems with the backlight brightness and it is possible this affects that.

I have deleted both the duplicate and the amdgpu.backlight=0, which both must have resulted from 1 of the 40 solutions I’ve tried. This issue has ranged across all distros and I can see that it’s not faulty hardware because for a few seconds before the distro loads up I get full brightness. Additionally the slider does work and alters a value between 0 and 255 in /sys/class/backlight/admgpu_bl0/brightness, oddly it does this backwards when the slider is empty its at 255 and the screen is at the max of it’s very limited brightness while when it’s full it is at 0 and at minimal brightness. As I previously stated I’ve checked close to 40 similar issues many with solutions and had 0 success, I haven’t even been able to change the aforementioned files manually due to a write error: input/output error that occurred after U tried to write when I changed permissions. I know I’ve already taken a lot of your time but sir please where do I go next?

just used xbacklight and it outputted the following: No outputs have backlight property. Could it be the system doesn’t read my backlight and I’m seeing without a backlight?

update: when running the systemctl enable backlight command it outputted, Failed to enable unit: Unit file backlight.service does not exist.

There isn’t a service file for systemd to start that service with, thus the message since you can’t enable something you don’t got. You could create one https://docs.fedoraproject.org/en-US/quick-docs/understanding-and-administering-systemd/

that is way above my pay grade I more so would like to know if the above information means my laptop is not picking up my backlight.

HP Victus new Vanessa installation backlight not working - Linux Mint Forums . this guy had the same issue and laptop as me except he’s on mint. Very long and no solution that I can see. smh what do I do?

If you noted the command I posted you saw systemctl status systemd-backlight@backlight.service The same name would be used to enable or disable that service.

However, if you are in as root (not just using sudo) you should be able to do the chmod and make a change to the content of the brightness file as I showed above and repeat here.

# chmod u+w  /sys/class/backlight/intel_backlight/brightness 

# ls -l   /sys/class/backlight/intel_backlight/brightness 
-rw-r--r--. 1 root root 4096 Nov  1 12:45 /sys/class/backlight/intel_backlight/brightness

# echo "8000" >   /sys/class/backlight/intel_backlight/brightness 

# cat  /sys/class/backlight/intel_backlight/brightness 
8000

The # at the beginning of those command lines shows I was in the root environment, which can be achieved by using sudo su -

Note that the path I used may or may not match for you since the ‘intel_backlight’ directory is hardware dependent. Using ls /sys/class/backlight should give you the proper directory on your system.

I have 3 files regarding brightness in my /sys/class/backlight/amdgpu_0 folder:
1.brightness: which the slider changes to a value from 0 to 255, and I can write to it,
this does nothing except change screen a bit brighter when at 0 and dimmer at 255.

2.max_brightness: which is set at 255 and cannot be written to regardless of permission.
(when try to write it outputs an input/output error).

3.actual_brightness: is at 0 and like max_brightness it cannot be written to (same input/output error).

To sum it up writing to that file doesn’t help me as it is functioning fine with the slider and the number reflects that, rather the screen has some other intrinsic issue

Additionally, I tried to set up ddcutil to use a gnome extension brightness changer and when I used ddcutil capabilities | grep "Feature: 10" it outputted Display not found. Please lmk if this along with all of the other info I’ve given points to the issue. This problem has been eating away at my days.

I have had annoying troubles with brightness on both of my laptops. I downloaded a program called “light” from the repos. It fixed things up.

thx for the suggestion, the program works and changes the brightness value, but my issue lies beneath that. It seems the slider and brightness file work but my backlight is stuck dim with only slight variation in brightness and dimness

There are some improvements for newer laptops coming with kernel 6.1, you could test it:

1 Like

I spent half an hour tying to fix the brightness, until I’ve seen this.
I restarted my toshiba satellite L750 labtop with an older kernel and my brightness options worked again.