Brightness broken and acting very strange

Hey, I just booted fedora on my new hp victus 15 gaming laptop. and I immediately realized the brightness was stuck on very low. When I use the keyboard buttons the slider works as expected, only the actual brightness will slightly decrease as the slider reaches full and brightens a bit as I make it the lowest. I’ve tried a bunch of forums trying to troubleshoot this. Something I noticed is when doing this tutorial How to Set Nvidia as Primary GPU on Optimus-based Laptops :: Fedora Docs my glxinfo | egrep “OpenGL vendor|OpenGL renderer”
output remained my non nvidia graphics. Not sure if that is helpful but i’m frustrated and any help will be appreciated, thanks!

  1. What version of fedora?
  2. What drivers? nvidia from rpmfusion? The FOSS nouveau driver that ships with fedora?
  3. Wayland or xorg?
  4. Workstation or one of the spins?
  5. Secure boot enabled or disabled?
1 Like

another important point before I get to ur question is that i’ve tried a few distros including pop OS and manjaro with their propietary driver versions and the same issue persisted. But as for ur questions.

  1. fedora version 36

4.workstation boot disabled

1 Like

Those nvidia files look good.
What is the output of dmesg | grep -iE 'secure|nvidia|nouveau' and lsmod | grep nvidia? Please run those commands shortly after a new boot.

Be aware that the instructions to make the nvidia gpu primary do not tell you the most critical point (they seem to think you already know.) and that is that the nvidia.conf file only works if using xorg and not wayland. After all the nvidia.conf file is placed at /etc/X11/xorg.conf.d/nvidia.conf thus is only read when x is configuring the devices.

There are a few other threads here about brightness on a laptop, not necessarily nvidia related, but some are dual gpu and there were solutions. I have not looked all of them up but you can do a quick search on this site and find them. I used ‘brightness laptop’ as search terms and found 46 different posts.

dmesg | grep -iE 'secure|nvidia|nouveau';

[    0.000000] Command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.0.5-200.fc36.x86_64 root=UUID=3754b232-100d-49d0-a006-4255cb95e66d ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
[    0.000000] secureboot: Secure boot disabled
[    0.003851] secureboot: Secure boot disabled
[    0.034127] Kernel command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-6.0.5-200.fc36.x86_64 root=UUID=3754b232-100d-49d0-a006-4255cb95e66d ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
[    4.992639] amdgpu 0000:06:00.0: amdgpu: SECUREDISPLAY: securedisplay ta ucode is not available
[    7.784107] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/0000:01:00.1/sound/card0/input16
[    7.784194] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.1/0000:01:00.1/sound/card0/input17
[    7.784270] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.1/0000:01:00.1/sound/card0/input18
[    7.784330] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.1/0000:01:00.1/sound/card0/input19
[    8.873190] nvidia: loading out-of-tree module taints kernel.
[    8.873197] nvidia: module license 'NVIDIA' taints kernel.
[    8.883073] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    8.951308] nvidia-nvlink: Nvlink Core is being initialized, major device number 509
[    8.951989] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
[    8.952081] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[    8.997887] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  520.56.06  Thu Oct  6 21:38:55 UTC 2022
[    9.079163] nvidia_uvm: module uses symbols nvUvmInterfaceDisableAccessCntr from proprietary module nvidia, inheriting taint.
[    9.160740] nvidia-uvm: Loaded the UVM driver, major device number 507.
[    9.199239] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  520.56.06  Thu Oct  6 21:22:53 UTC 2022
[    9.203192] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[   10.026281] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1

lsmod | grep nvidia:

nvidia_drm             73728  1
nvidia_modeset       1187840  2 nvidia_drm
nvidia_uvm           2854912  0
nvidia              55250944  97 nvidia_uvm,nvidia_modeset

As for the wayland issue, is there a way to switch either my windowing system or make a config file that works.

I will take a look at some of those potential solutions because as far as i know my issue could be something completely unrelated to the things i’ve been trying. thx

Hello @lernerearnerburner123 ,
Welcome to :fedora: .
Just out of curiosity, are you running Gnome? I notice on the laptop I have Gnome running on, it was initially dimming the screen irrespective of whether the AC was plugged in or not, and I had to reconfigure all of the power settings. It seems that the defaults for power mgmt on laptops is leaning heavily towards the battery life preference.

no because i’ve tried multiple DEs and distros all with this problem staying consistent. But after getting to fedora i fell in love with this distro and am hoping I can resolve it and keep it.

1 Like

idk if this is repeating info but when I booted at some point I got a xorg-x11-drv-nouvea system-failure in problem reporting

I think the nouvea driver is the open one, are you running the proprietary nvidia driver? Sorry, I got no nvidia hardware in use at this time.

In think so I did the nvautoinstaller, but I have zero knowledge of nvidia hardware. I was aware of the potential pitfalls of it’s compatibility with linux but microcenter had a sweet deal and I couldn’t resist.

The last time I had anything to do with nvidia video drivers on Fedora was with an MSI board I was running for awhile, I used an nvidia card with that system. I seem to remember an application available called ‘green with envy’ I think. It was a utility for configuration of the nvidia cards and it allowed me to use the features of my card easier.

According to that the nvidia driver is properly loading and active.
However, brightness is not controlled by the nvidia driver.

when i start up laptop, the brightness is good until the fedora or whatever other distro symbol pops up and starts loading, do u have any idea what else it could be?

I will repeat the above from an earlier post. I suggest you search and read a little instead of depending upon the rest of us to hand you the answer. I know that several of those had solutions posted. I would have to do the same to make a good suggestion.

Please remember that all of us are volunteering our time, we likely do not have the exact same equipment and software you do, and we can provide advice but not a bulletproof answer.

i’m aware of this, and i’ve spent many hours digging through forums and trying solutions. Was just hoping sombody here could help me.

can u please guide me in the right direction, it isn’t a GPU issue as I’ve ruled it out I’ve tried different kernels and that didn’t either help. I’ve also tried a bunch of grub config things. where do I look next?

ISTR that there may be a brightness setting somewhere under /proc or /sys for the laptop screen. I don’t remember where and cannot at the moment look. There may be one only for the iGPU or dGPU or both iGPU & dGPU depending upon the hardware and the OS. Since I would have to research that it seems better to ask you to do that research.

I also seem to recall that there may be a max brightness value as well as a brightness value.

The settings may exist under /sys/class/backlight/

You are welcome!

is all I have but It won’t let me do anything with it . I also have another file with the same path except it’s called actual_brightness idk the difference. I’ve also tried this .

I have powered up my laptop and find this.

# ls -l /sys/class/backlight/intel_backlight/
total 0
-r--r--r--. 1 root root 4096 Oct 31 10:11 actual_brightness
-rw-r--r--. 1 root root 4096 Oct 31 10:11 bl_power
-rw-r--r--. 1 root root 4096 Oct 31 09:16 brightness
lrwxrwxrwx. 1 root root    0 Oct 31 10:11 device -> ../../card0-eDP-1
-r--r--r--. 1 root root 4096 Oct 31 09:16 max_brightness
drwxr-xr-x. 2 root root    0 Oct 31 09:16 power
-r--r--r--. 1 root root 4096 Oct 31 10:11 scale
lrwxrwxrwx. 1 root root    0 Oct 31 09:16 subsystem -> ../../../../../../../class/backlight
-r--r--r--. 1 root root 4096 Oct 31 09:16 type
-rw-r--r--. 1 root root 4096 Oct 31 09:16 uevent

# cat  /sys/class/backlight/intel_backlight/brightness 

# cat  /sys/class/backlight/intel_backlight/max_brightness 

# chmod u+w  /sys/class/backlight/intel_backlight/brightness 

# ls -l   /sys/class/backlight/intel_backlight/brightness 
-rw-r--r--. 1 root root 4096 Nov  1 12:45 /sys/class/backlight/intel_backlight/brightness

# echo "8000" >   /sys/class/backlight/intel_backlight/brightness 

# cat  /sys/class/backlight/intel_backlight/brightness 

Thus I see that brightness is not writable, but it can be changed using the chmod command, then modified.
I also see that the max allowed value is about 3 times the current value so I reset it slightly higher so I could see the effect.

switched the permission but getting an input/output error when I try to write to the files. I am sorry about the time this is taking, but I really appreciate ur efforts.