Brave Browser and other apps that "can't" be installed on Silverblue

I just wanted to see what folks are doing with software that currently can’t be installed with either rpm-ostree or flatpak.

The rpm available for Brave installs to /opt, so currently can’t be overlaid in Silverblue (unless that changed very recently). I’m also trying to keep my Silverblue install as “pure” as possible, so am avoiding adding additional repos, including both 3rd party and rpmfusion. I’ve attempted to work on building out a flatpak for Brave, but don’t know enough at the moment to get around the sandboxing issue with Chromium based browsers. I have no interest in running it with --no-sandbox for security reasons.

I was able to install a binary release of Brave from their github releases into my home directory and hack up a desktop file to launch it, so that is working for now (no updates, plus I may be missing stuff I am not even aware of). I suppose I could install in a toolbox container and put together a script to launch it (called from a desktop file) but not sure what that buys me.

So what approach do you take if your favorite piece of software isn’t exactly Silverblue friendly?

It actually did!

The next release of rpm-ostree should have support for layering packages that install into /opt. There are some caveats (the use-case was layering in Google Chrome), but it should unblock more packages from being layered.

Personally, I’ve been trying to use alternatives and/or go without pieces of software. I’ve not found any deal-breakers for me, but my required pieces of software are pretty minimal. YMMV.

A real stretch workaround could be running your favorite piece of software in a VM, but that seems like a lot of resources to utilize to just run Brave (using your example).

1 Like

Well I guess that answers my question then! Still kind of breaks my “clean system” paradigm, but one little repo added can’t hurt I suppose. :smile:


SpiderOak ONE backup was the one I really couldn’t live without, and it can be installed unpriviledged - you just have to unpack the binaries in your home directory rather than /opt.

I’m still trying to get the AMD “ROCm” stuff to work but that’s all built from source anyway.

i tried the community-maintained brave-snap (works fine on kde neon, but under silverblue 30 beta - no way (massive cpu load). why brave is still not delivered as flatpak when it comes to linux is a mystery to me.

is it possible to run brave in/out of “fedora-toolbox”?

I also tried the snap and experienced a similar issue. Creating a flatpak for Brave is akin to creating a flatpak for Chromium, and is not that simple a problem to solve due to sandboxing. I think there are folks working on it.

Yes. I did this and it worked well. Fonts were a little off initially, but I installed a Gnome GUI app in my pet container and that fixed the issue (pulled in stuff I didn’t want to bother figuring out). I also created a script to launch Brave from the container and used that in my desktop file. I no longer run it this way, as I found it more convenient just to grab the releases from here and run out of ~/Applications: Releases · brave/brave-browser · GitHub

1 Like

There’s an upstream issue that is tracking any Flatpak progress, but it doesn’t appear to be a priority for the developers right now - Make brave available through Flatpak and Flathub · Issue #1000 · brave/brave-browser · GitHub

thx @kcalvelli @miabbott … well, then i do not try it via toolbox and download the zip file. let’s see. & yes, thx for the link. finally it will be a “community-maintained” flatpak solution. i just wonder right now if brave is worth it. i have (meanwhile) my doubts.

I have questioned whether Brave is worth all the effort as well. I’ve been running the latest nightly and am very pleased with the performance, love that I can use Chrome extensions, and certainly am sold on “Brave Rewards,” so I am using it for now.

However, I do have some reservations:
1 - From an aesthetic standpoint, it doesn’t integrate that well with Gnome. It’s on par with other Chromium clones and with Firefox, but still breaks up my desktop experience a bit. Epiphany’s latest release is the best I have seen from an integration/aesthetics standpoint.

2 - I use a 2 in 1 laptop and browse often in tablet mode. Unless I am browsing full screen, I need to enable the system titlebar in order to drag browser windows, which, well - see my point above. Epiphany doesn’t have that problem.

3 - Not Wayland. Not even sure they know what Wayland is. I have been hearing for a while that work on Chromium Wayland is “close” but that doesn’t mean it will make it to Brave.

Ha. I think I just convinced myself to give Epiphany another spin :slight_smile:

1 Like

I feel like Flatpak is maturing rapidly. The amount and quality of available applications on Flathub is growing steadily and thus so will the priority for upstream developers. I’d expect a pivot in developer mentality pretty soon, where upstream developers are only going to focus on and support Flatpak and/or Snap packages and not bother with providing and suporting DEB/RPM package installation. Fedora could speed this transition up by switching all default apps available on Flathub over to Flatpaks on vanilla Fedora Workstation…

In the mean time my strategy for all applications like this (e.g. with alternatives) is to do without, put it on my wish-list and monitor application issue trackers for progress. Like Brave, most unavailable applications have a feature request for Flatpak packaging by now. Don’t feel like polluting my Silverblue deployment with a lot of layered packages!

1 Like


hm, epiphany is available as flatpak, but quite outdated. is the “normal” - version more up-to-date?

the browser is the most used software (for regular users). and currently there is no alternative (except ff, which i don’t want to use) if you don’t want google to spy on you.

the “ungoogled-chromium” appimage is based on an ancient chromium version and contains a questionable extension which can’t be removed and the (previously excellent) irdidium - browser won’t be further developed (as it seems). brave indeed looks horrible (from the mentioned aesthetic point of view) on sb/gnome. it’s a pain in the eyes. also there were/are some other problems with brave: special facebook-connections not blocked, a questionable header, et cetera. maybe this has already been fixed because of the bad press - i don’t know.

so one has no choice but to use ff at the moment (and plays around with the config for half an hour) or go to the very dark side of power and layer chromium (and i won’t go into google chrome at all).

ps: i guess, only the non-official ff - nightly flatpak can handle wayland at the moment. but I read somewhere here, that this version is also outdated and updates are not possible.

so one have to wait and see - how @toMeloos has written… .

Brave did offer an explanation re: the Facebook thing and has made some other changes based on that bad publicity you mentioned. I am running the binary out of my user dir but am not 100% happy with that. I want to run all of my apps from Flatpak if I can.

As for Epiphany, I installed the tech preview from gnome-apps-nightly and it seems to meet about half of my browsing needs. It definitely looks great, but the lack of webRTC functionality limits my ability to switch over completely. Note: to install the tech preview, you need to remove your existing Epiphany flatpak and install the Devel version, iirc.

thx @kcalvelli , yes, i have read yesterday on github (or was it reddit or both) similar statements concerning brave. i remember - even b. eich has written a comment. but … you know … trust has to be earned. this is a long process and trial/error is included. and this was a huge error.

at the moment i’m using ff, but try epiphany from gnome-apps-nightly, as you described. i removed the flatpak anyway.

webrtc is imho a security/privacy - risk. especially when using a vpn. therefore, one option less on ublock origin, one option less on firefox (config) or one extension less on brave (as far as webrtc is concerned).

let’s take a look at epiphany. these are only temporary solutions anyway.


Agreed. Still … I’m willing to give Brave the benefit of the doubt here based on Eich’s involvement. In fact, I just layered Brave with rpm-ostree using the instructions here: Installing Google Chrome on Fedora Silverblue - #2 by JohnMH

uh … is that now possible … even with brave & without

vi /etc/yum.repos.d/

? well, if this is really the case i just try it - but from now on always with what happened in mind; therefore firefox won’t be “override remove(d)” anymore & epiphany remains an option (when another technical problem i just have is solved).

thx @kcalvelli & @JohnMH @sb-team @gnomealex

You can’t install via the repo. You need to download the rpm direct (so no prod) from

@kcalvelli awsome, thx! simple to “layer” and works perfectly. now i have

LocalPackages: brave-browser-dev-0.64.37-1.x86_64

in the ostree. is the dev version of brave stable enough, do you have any experience with it? how about updates (rpm-ostree update = brave updates too (as a local package?)

ps: & the mentioned privacy-problems have been fixed (preferences -> social buttons and logins) + one can still install umatrix and check brave’s block - behaviour more closely.

I haven’t experienced any stability issues at all running the dev version, but … it’s still the dev version, so your mileage may vary. This installation method does not allow for auto-updating, since we installed the rpm directly as opposed to from a repo. You will need to update on your own when a new release becomes available.


manual updates, ok. well, it is only temporary. until a flatpak comes out. that will be necessary even for brave. let’s see & try it out. the first bug: if, for example, you want to manage cookie-blocking, not all options are displayed in the menu, but they appear when the mouse pointer is above them. nothing earth-shattering. + brave://gpu = video decode : unavailable - still. but very low cpu - load compared to firefox or chromium (+ IPFS - seems to be interesting).

ps: css exfil

Okay, I’m wrong! I rebased to silverblue 30 from rawhide, and was able to add the repo by creating it manually in /etc/yum.repos.d. Previously when attempting to add the repo via the link provided on the Brave website, I was getting the read-only filesystem error. Not sure why I never thought to add it manually!

I still haven’t figured out how to add the gpg keys using the link provided on the brave website, so I’m running with gpgcheck=0 which is horrible, I know.

But updates work.