Boot crash/kernel RP PIO log size invalid


Recently I installed fedora 37 from usb, updated the software and installed some stuff (ide, messenger and “Development Libraries” group packages)

I have restarted the system before and it worked but now it seems to crash on boot.
It’s a dell precision with i9-12900H and nvidia A2000.

From emergency mode I ran .

$ journalctl -k -b -p 1 err

This was the result.

<date> <hostname> kernel: pci 0000:00:07.0: DPC: RP PIO loge size 0 is invalid
<date> <hostname> kernel: pci 0000:00:07.0: DPC: RP PIO loge size 0 is invalid
<date> <hostname> kernel: ucsi_acpi USBC000:00: unkown error 0
<date> <hostname> kernel: ucsi_acpi USBC000:00: UCSI_GET_PDOS failed (-5)
<date> <hostname> systemd-gpt-auto-generator[1710]: Failed to dissect: Permission denied
<date> <hostname> systemd[1696]: /usr/lib/systemd/system-generators/systemd-gpt-autogenerator failed with exit status 1
<date> <hostname> kernel:
<date> <hostname> kernel: dell_smm_hwmon: Unable to get dell smm signature
<date> <hostname> kernel: usb usb3-port10: disabled by hub (EMI?). re-enabeling....
<date> <hostname> kernel: bluetooth hc10: Failed to send Firmware data (-19)
<date> <hostname> kernel: bluetooth hc10: Sending frame fail (-19)
<date> <hostname> kernel: bluetooth hc10: Failed to read MSFT supported feature (-19)
<date> <hostname> kernel: watchdog: watchdog0: watchdog did not stop! 

It seems to be a usb and/or bluetooth issue. I found this bug report From what I can tell it’s fixed and merged in
kernel 6.1 when I list installed kernels I see i’m on v6.0.7 I was running ubuntu before for a few month and it worked. Has ubuntu patched this or is it on a newer kernel than fedora?

The only solution I see is looking into getting a 6.1 version of the kernel, is this the right move?

Help would be greatly appreciated.

You are far from up to date.
The current fedora kernel on f37 is 6.0.15.

I would suggest that you do a full update with dnf upgrade --refresh which should upgrade everything on the system to the latest versions, then reboot and see if the software upgrades may have fixed the problem.

Oh wow, I have done the upgrade command after install but unsure if I added the refresh. My full version atm is 6.0.7-301.fc37.

Currently I am stuck in emergency mode and i’m considering reinstalling to avoid messing up any nvidia drivers or kernel hassle. Will investigate how to install/update kernel from usb and report back once I am on the current kernel.

This is the original kernel from installing f37. Update was not done for the kernel, even if other items were updated.

If this is a new install and this is happening then a reinstall will be much faster than tracking down the problem from emergency mode.

1 Like

I ended up re-installing since I was stuck in emergency mode it would be faster. After initial I upgraded to the 6.1 kernel from the vanilla repo. The nvidia drivers weren’t working with the 525 drivers (installed by dnf). I had the headers etc but it complained about a dir missing.
So I tried going to a later kernel from vanilla.

After this I added the nvidia drivers (525.60…) from rpm fusion. This has been working without issues for about a day now So not really a answer to the root of the problem but I managed to fix it.

Thanks for pointing out me messing up the initial kernel version. Still unsure why it worked at first , for a few reboots even.

Will have to research how I am going to handle running updates in the future until 6.1 is in the default install.