Boot cannot start Display Manager and halts

After an automatic upgrade, Fedora 30
Fedora (5.3.6-200.fc30.x86_64)
stops at the instruction
Started GNOME Display Manager.

Can go to Terminal prompt by pressing
and login as root.
What can I do from there?

There is a ver. 12 kernel that can boot, but can work with local programs only.
Its Firefox cannot open any page but Gmail in old version.

All files are intact.

Heeeeeey! @mackissack

Its been 6-months already? Have you tried running selinux in permissive mode? Sometimes that happens because of an unresolved issue in selinux. Most times, an update fixes that. So, try updating first. You can do that from the terminal.

as root:
dnf -y update

If that didn’t fix it, then add the following to your kernel boot parameters, and boot again:

If that fixed it – Yaaaay! However, that’s a temporary fix. It is not good to run without security. You’ll need to find out why Selinux is messing with your booting experience. In that case, I’d suggest that you install a more recent Fedora. Fedora-32 will suffice. It makes more sense to fix bugs in releases that have longer lifespans. Fedora-30 will reach End-Of-Life (EOL) next month.

1 Like

Hello, @twohot.
Well, sorry it took me so much time. Couldn’t I got stuck.
My computer wouln’t pass that boot process and didn’t know what to do.
Couldn’t find any answer in forums I tried, all via my mobile.

Well, I got to the login prompt and started the update.
It worked until reaching a 1.6 GB pycharming file and seemed to get stuck there again for about 7 hours.
I reset the machine and boot would halt at start of Display Manager again.

So, again to login and started the update process again.
Now it says repos cannot be found in mirrors.
“Failed to download metadata for repo…”
Repos phraceck-PyCharm, adobe-linux-i386, adobe-linux–x86_64, fedora-cisco-openh264.

Next attempt to update and only cisco repo fails.
And there I a, retrying.

Bro …something weird is going down in that box. What’s a pycharming … eh?

You may need to disable all repositories that are not from Fedora and update your system first

I will thank you for your patience.
I’m not so skilled.

While updating it was about to reach the end, file 639 of 670 or so when a big 1.6 GB was being downloaded.
It was named something like pycharming-community.
However, it took too long.
Couldn’t see if there was any progress.
Modem Internet led blinked but after 7 hours the HDD didn’t blink.
I decided to reset the system.
When reaching the prompt I tried to start the update again and now the failure of downloading metadata showed up.

I haven’t called any repos myself.

Hi, @twohot.
The mess was due some enforcing=0 and single instructions I wrote at the grub entry.
They put the machine in rescue mode.

Solved that and the update went smoothly.
Finally the update solved the display problem.

Thank you very much, @twohot

I’m glad you are enjoying your Fedora now. Don’t forget to mark/tick the post that solved your question.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.