Bluetooth vs Wifi Interference/Coexistence - Driver Ath9k

Hi everybody,

When I connect any bluetooth audio device to my laptop, the wireless drops down and I can no longer use the internet untill I turn off the bluetooth.

I have tried a lot of tutorials I found on the internet, but so far no sucess.

Even adding “options ath9k btcoex_enable=1 bt_ant_diversity=1” to /etc/modprobe.d/bluetooth-audio.conf worked for a while, but suddenly the internet freezes again.

I’m new at Linux and tried other distros, all with the same problem.
I’m a big fan of Fedora and would like to use it as my daily system, but with this annoying problem I’m affraid I’ll have to give up and turn back to Windows.

My bluetooth/wireless driver is Ath9k (Qualcomm Atheros QCA9565 / AR9565).

Anybody has any ideia that could help me?

Thank you


Quick google search produced results, that suggests changing entry in bluetooth-audio.conf:

options ath9k nohwcrypt=1 blink=1 btcoex_enable=1 bt_ant_diversity=1

May help.

Thanks Tom.

Hi Tom,

I have tried “nohwcrypt=1 btcoex_enable=1 bt_ant_diversity=1” in many variations, none effective worked.

I’ll try “blink=1” and see the results.

Thank you.

HI again, unfortunatelly it didn’t work.
Did your tried to use the Wi-Fi channels 13 or 14 (if this legal)? They, according to link above, are not interfere with Bluetooth (see figure-table-diagram).

1 Like

Yes, I did. The problem actually occurs only on my laptop when using Linux. It doesn’t drop down when usind Windows nor other devices.

Maybe: Did your tried to use the flags mentioned above by tjdoyle and this Wi-Fi channels simultaneously?

Hello vist95,

Yes, tried both configurations at the same time. It works for some moments and then freezes the internet again.

Thank you for your help.

1 Like

Same thing happened with me , I am using fedora 30 kernel 5.5.16 . rtl8723de chipset . At first I didn’t find the drivers . Then I manually installed them from github after a big headache . But now when I turn on wifi Bluetooth stops working . I can use only one of them , Tried everything from internet even ubantu and mint forms . But nothing worked . Please tell me if you found any solution .

I didn’t found a solution, at the end I gave up and I’m not using Linux on that laptop anymore. It’s a pitty.

wifi not working in latest kernel(5.5.13-arch2).
i stay at downgraded kernel(5.5.10.arch1-1) until fixed but i think i should inform you.

adapter : Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
taken from: FS#66061 : [linux] latest kernel wifi issues with ath9k

It is possible to install 5.5.8 kernel from: You need at least kernel and kernel-modules.