Bluetooth issues with latest kernels on F40

hi. I have a problem in F40 on a Dell Venue 7140 that is a real problem and I cannot find a fix for it.
Been using Fedora since 30 and got it really working well since 32, ie everything does what it should. Upgraded many times, and had small issues but always found solution.
On F40 upgrade and first kernels all OK but from the last few kernel upgrades have a power issue.

When undocked the bluetooth stops working. Can use touchscreen to disable BT and re-enable but then tablet becomes unusable. Odd thing is when trying to power off the menu option appears but no restart option just Power off or Logout, neither of which work.


have tried various kernel settings,

kernel=“/boot/vmlinuz-6.8.9-300.fc40.x86_64”
args=“ro rootflags=subvol=root rhgb quiet snd_intel_dspcfg.dsp_driver=3 usbcore.autosuspend=-1 acpi_osi=‘Windows 2009’”
but no change to behavior.
Have tried cstates on and off.

Does anyone have any solution or a hint on where to start looking?

I used Koji to install kernel version 6.6.0-61.fc40 down from 6.8.9-300.fc40 and everything works as it should.