Bluetooth file sending fails

I’ve never been able to get Bluetooth to work on Linux. I’ve been unable to send files to my Samsung Android 6 mobile from several distributions. I was trying out elementaryOS 7.1 yesterday and found that it worked immediately, so I know that my hardware works.

I was therefore encouraged to try again on Fedora, I’m now on Fedora-39Beta. It didn’t work, it claimed “Connection refused (111)” - well it didn’t even ask :), there was no question on my mobile.

The desktop shows a panel with a rectangle with coloured circles at the top and below:
Connection On
Paired Yes
Type Phone
Address xx:xx:xx:xx:xx:xx:
Send Files
Remove Device

It would be nice to fix this problem at last.

I tried this with my Huawei Android 6 mobile and it worked. I removed every reference to the Samsung on both desktop and phone and tried again and it worked. It is however a rather awkward thing to do, I have to open settings and select the mobile. I would have thought it should be available from the Files application.

It’s stopped working since I moved to a new disk. Everything looks good on both devices, except that the “Send Files” button is greyed out. I’m using Fedora-40 Beta, so I shouldn’t expect everything to work, however maybe it should be looked at before the official release.