Bluetooth error after updating system

hello colleagues I have a problem, after updating the system bluetooth stops working, it seems to me that it has to do with the kernel.

when I try to update pulseaudio-module-bluetooth I get the following error.

    Error: Transaction test error:
      the /usr/lib64/ file from the ldacbt- installation conflicts with the libldac- package file
      the /usr/lib64/ file from the ldacbt- installation conflicts with the libldac- package file

when I enter the command bluetoothctl in the terminal


Agent registered
[bluetooth]# devices
No default controller available

I hope you can help me solve this problem. thanks

Do you know how I should update ?, every time I install the OS I start with yum -y update to update everything. Is there a correct way to do it to avoid having that problem? thanks

If you prefer online upgrade then:

sudo dnf upgrade

Otherwise, you can use offline upgrade.

Set up priorities to prefer official repos over third-party repos as mentioned above.

Good, according to what I read in the other post you disable some repositories. I just reinstalled fedora now in kde and am trying to update successfully

These are the repositories that it shows me, could you tell me which one I should disable to avoid problems

# sudo dnf repolist                              
id del repositorio                                                       nombre del repositorio
fedora                                                                   Fedora 33 - x86_64
fedora-cisco-openh264                                                    Fedora 33 openh264 (From Cisco) - x86_64
fedora-modular                                                           Fedora Modular 33 - x86_64
google-chrome                                                            google-chrome
rpmfusion-free                                                           RPM Fusion for Fedora 33 - Free
rpmfusion-free-updates                                                   RPM Fusion for Fedora 33 - Free - Updates
updates                                                                  Fedora 33 - x86_64 - Updates
updates-modular                                                          Fedora Modular 33 - x86_64 - Updates

I would be grateful if you could indicate the order or commands that I should enter

1 Like

The listed repos should be compatible, and generally work well.
By the way, this kind of issue can be usually solved without reinstalling relatively easily.

the two different commands ( dnf and yum) behave very differently.

Dnf attempts to resolve all dependencies and install them as required. Yum does not and you are left with messages about needing other packages as you posted. Dnf also gives you more detailed messages that help identify the actual problem if there is one. Most of the errors I have seen with dnf have been related to delays in sync of the repo mirrors. Waiting a short time and trying it again usually fixes those.

Try doing the installs and upgrades with dnf instead of yum and see if that fixes the problem for you. The command is identical “dnf -y update”.

dnf -y update

After updating in this way, I had problems with the bluetooth, it can no longer be activated.
Any suggestion?

Try to boot with a previous kernel version.

when you update you have kernel 5.10.13-200 and blutooth stops working.

when I enter with the other kernel 5.8.15-301 that was not updated it works normal.

1 Like

if you run this command
sudo dnf remove ldacbt
ve will affect the user interface

Removing dependencies

 kde-print-manager                                  x86_64                         20.08.1-1.fc33                            @anaconda                           1.7 M
 krfb                                               x86_64                         20.08.1-1.fc33                            @anaconda                           2.1 M
 krfb-libs                                          x86_64                         20.08.1-1.fc33                            @anaconda                           286 k
 kwin-wayland                                       x86_64                         5.20.5-1.fc33                             @updates                            1.5 M
 plasma-desktop                                     x86_64                         5.20.5-1.fc33                             @updates                             26 M
 plasma-workspace                                   x86_64                         5.20.5-3.fc33                             @updates                             26 M
 sddm-breeze                                        noarch                         5.20.5-3.fc33                             @updates                            971 k

this is corrected by running
sudo dnf install libldac


You could do “sudo dnf remove ldacbt --noautoremove” and avoid removing the dependencies.

it keeps showing me the same dependencies to remove

 ldacbt                                             x86_64                                          @unitedrpms                           68 k
Eliminando dependencias:
 kde-print-manager                                  x86_64                          20.08.1-1.fc33                          @anaconda                            1.7 M
 kde-print-manager-libs                             x86_64                          20.08.1-1.fc33                          @anaconda                            530 k
 krfb                                               x86_64                          20.08.1-1.fc33                          @anaconda                            2.1 M
 krfb-libs                                          x86_64                          20.08.1-1.fc33                          @anaconda                            286 k
 kwin-wayland                                       x86_64                          5.20.5-1.fc33                           @updates                             1.5 M
 pipewire                                           x86_64                          0.3.21-2.fc33                           @updates                             379 k
 pipewire-libs                                      x86_64                          0.3.21-2.fc33                           @updates                             4.1 M
 plasma-desktop                                     x86_64                          5.20.5-1.fc33                           @updates                              26 M
 plasma-integration                                 x86_64                          5.20.5-1.fc33                           @updates                             478 k
 plasma-lookandfeel-fedora                          noarch                          5.20.5-3.fc33                           @updates                             1.2 M
 plasma-workspace                                   x86_64                          5.20.5-3.fc33                           @updates                              26 M
 plasma-workspace-wayland                           x86_64                          5.20.5-3.fc33                           @updates                              43 k
 plasma-workspace-xorg                              x86_64                          5.20.5-3.fc33                           @updates                              59 k
 sddm-breeze                                        noarch                          5.20.5-3.fc33                           @updates                             971 k
 xdg-desktop-portal                                 x86_64                          1.8.0-1.fc33                            @anaconda                            1.6 M
 xdg-desktop-portal-gtk                             x86_64                          1.8.0-1.fc33                            @anaconda                            631 k
 xdg-desktop-portal-kde                             x86_64                          5.20.5-1.fc33                           @updates                             712 k

Resumen de la transacción

What is the difference between working with an updated kernel version and the one that comes by default?

Those depencencies should not be listed for removal if you added the --noautoremove option to the dnf command.

There are a lot of different things updated when a kernel update happens. I would not be able to identify them, but since the F33 release date was in November, lots of updates have occurred since, including the kernel going incrementally from 5.8.15 to the newest which is 5.10.13.

I did a bit of research on the problem reported in your initial post. It reports a conflict between the ldacbt and the libldac packages. I easily find the libldac package and have it installed on my system. However, I find the ldacbt package listed in no official repo, and in fact the library file that conflicts is only provided by the libldac package in fedora.

I also have the pulseaudio-module-bluetooth package installed from the fedora repos and it has no requirements for a package named ldacbt.

I suspect the error is because you installed something from a third party repo (unitedrpms) that has different dependencies than the standard fedora repo and thus conflicts.

The link you were provided by vgaetera showed the same conflicts and appears to have been resolved by disabling the repo causing the conflict then removing the package That “unitedrpms” repo which caused the conflict on that link is also where you got the ldacbt package so your conflict is caused by the same third party repo.

If the package ldacbt is installed, remove it. In fact these two commands will likely fix the error

sudo dnf --disablerepo unitedrpms* remove ldacbt --noautoremove
sudo dnf install libldac

After you are certain that package is not going to conflict then reinstall or update the pulseaudio-module-bluetooth package while making certain that no repos except the standard fedora repos are enabled.

Your repolist posted earlier does not show the unitedrpms repo, but the fact that a package already installed came from there shows it was enabled at some point since you installed this system on the machine.

The error comes from updating with dnf update or yum update after reboot.

I tried to install and / or update the pulseaudio package to try to control the device’s power but it did not work, from there I started to notice the error of the packages.

I will try to carry out the commands you indicate, although the last time I deleted I was unable to start the session, the plasma was damaged.

Do you have any guide on how I should proceed to update with the correct repositories?

One problem at a time.
You cannot do a routine update with that conflict so fix the conflict as recommended.

Once that is successfully done then the next thing to do is a “dnf upgrade” to get all the packages up to date. If any more errors crop up then we deal with them one at a time.

removing that package ruined everything again.
I had to reinstall the OS and I tried updating only the kernel, after restarting the bluetooth stopped working.

Could we say that it is kernel problems or incompatibility?

In the end it was solved by updating the kernel. It started working in version 5.10.19-200.fc33.x86_64

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.