Bluetooth can't find (some) devices

I am using a F38 distribution. When trying to connect my Xbox One Controller, it won’t show up in the Bluetooth settings of GNOME. Same goes for bluetoothctl & blueman. I already tried updating the system, restarting, reinstalling bluetooth-related packages. Hower it does detect a Samsung TV

Bluetooth Adapter: Bus 001 Device 006: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)

I ensured that the controller & Bluetooth worked using Windows. This issue is only present here.

You will probably need something like this:

I already have this installed via the Terra Repo, and it is not part of my problem. My problem is that almost no devices are detected like my phone via Bluetooth.

Hi, I am facing the same issue with 6.4.* kernels and same bluetooth chip.

The last kernel working correctly is version 6.3.12 from fedora repos.

I cant see any related error messages from kernel logs. I am not sure it is a common issue with 6.4.* kernels or related to Fedora’s kernel build.