blivet.errors.DeviceTreeError: could not find parent for subvol


#1

The system auto submited a report to bugzilla but there is no reply yet. I guess they are busy with the migration to 5.0.

My problem is like this:

  1. I dd Fedora Server 29 ISO to usb
  2. boot from usb
  3. After choosing Language, then I got the above error, and installation cannot continued.

I have just one Harddisk connected while doing the installation. It is an active disk with Fedora 29 just upgraded via dnf.

  • It runs OK after upgrade, but after dnf autoremove, startx failed. So I want to do an inplace upgrade. But the installer do not allow me to proceed.
  • My active HDD is still bootable to text mode.
  • while startx failed for my userID, sudo startx works.

I don’t know how to resume my system to working status now.


#2

Can you use dnf history and dnf history rollback to try and revert? What exactly isn’t working with startx? Did you try checking the X server logs?

Also try sudo rm -f $HOME/.Xauthority and then run startx again (as your normal user, not sudo). If the file’s permissions get messed up, only root would be able to access it.


#3

Hi @refi64,

This is the Xorg.0.log, when started from my own user.

I have removed ~/.Xauthority before starting startx. I have no idea after reading the log file, what is wrong.

I will read more about dnf history and dnf history revert, and see if it helps.

Will update back.

Thanks a lot!


#4

This is the output of my dnf history
74 | install @gnome-desktop | 2018-11-05 20:14 | Install | 363
73 | remove @gnome-desktop | 2018-11-05 19:50 | Removed | 610 EE
72 | remove x2go* | 2018-11-05 19:42 | Removed | 23
71 | distro-sync --best --all | 2018-11-05 18:58 | E, U | 4 EE
70 | distro-sync | 2018-11-05 18:52 | D, U | 6 <
69 | | 2018-11-04 21:53 | Install | 2 >
68 | | 2018-11-04 21:52 | Removed | 1
67 | autoremove | 2018-11-04 21:38 | Removed | 198 ##
66 | update | 2018-11-04 19:50 | Upgrade | 149 EE
65 | update | 2018-11-02 12:25 | Upgrade | 8 <

After ID:67, my startx failed to start.
Would you please advice the correct “dnf history rollback” command for me to try? I tried “dnf history rollback 67”, but nothing happened.


#5

I think it would be dnf history rollback 66, since that’s when the upgrade occurred.

Two questions:

  • What’s the exact startx command line you’re using? By the description, you seem to be running it manually. Is GDM not working? Is it failing to sign in? Have you tried Wayland instead?
  • Try running it again, letting it crash, then running journalctl -b and saving + uploading the output.

#6

I have tried different ID from large to small, up to 60. All did nothing. So might be my dnf database is too problematic to roll back. I given up.

I am doing boot to Text mode. Then just by ‘startx’ to start Gnome deskto when needed.

Will do and update back soon.

Thank you very much!