Blank screen when starting Xorg with NVIDIA driver


When I start Xorg with the NVIDIA proprietary drivers and my eGPU connected to my laptop, it only shows a blank screen. I tried to decipher the Xorg.log file but I don’t know enough about GPU and drivers to see what could be the issue. Any help is much appreciated!


Here’s the details of my configuration:

Here’s the kernel arguments I’m passing on boot:

rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init

I also have a /etc/X11/xorg.conf file with:

Section "Module"
    Load           "modesetting"
    Load	   "glx"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    BusID          "4:0:0"
    Option         "AllowEmptyInitialConfiguration"
    Option         "AllowExternalGpus" "True"

and here’s a dump of my Xorg.log file: Xorg.log · GitHub

Maybe trying the solution in this thread might help you when booting up to a black screen:

No luck, it freeze Xorg completely.

What happens if you do not have the external monitor attached? Does the laptop screen function properly?

Some devices have had an issue with external monitors & nvidia while running wayland, but the external monitor works normally when logged in with xorg. It would be worth checking that out in your situation.

I’d run dmesg | grep nvidia to see if there were errors loading the module. It may be falling back to nouveau. Also check lsmod | grep nvidia to see if the module is loaded.

I found the issue later yesterday. It was caused by my settings to scale my HiDPi screen. These settings where in my ~/.Xresources. Maybe they weren’t picked up or something was making Xorg/NVIDIA driver unhappy.

Anyway, I added xrandr --auto in my ~/.xinitrc to override all settings I use and it solved the issue.

Thanks everyone who tried to help :wink:

1 Like