Blank Screen Forces Windows to Primary Display

I’m currently running F34 with GNOME 40.0 and kernel 5.11.11-300 on a dual monitor setup and when my screen blanks (as I’ve set it), all open windows are moved back to the default display; am I missing a setting somewhere to not have that happen?

1 Like