Blank screen at boot with 6.3 kernels and AMD GPU. The 6.2 kernel still works

I am unable to boot into Fedora with any 6.3 kernel. The screen goes blank, and then my monitor turns on and off repeatedly. It never gets to the password screen to decrypt my hard drive.

Only the old 6.2.15-200.fc37 works.

I’ve tried 6.3.8 with the module_blacklist=ucsi_acpi parameter and only get:
Booting a command list then just the blank screen again. 6.3.8 without the parameter returns the same blank screen.

The results of the fpaste command:
fpaste file

Before digging deeper into this:

We have already builds of the future Linux kernel (6.4.X). This is not yet eligible for production. This kernel is thus not intended to become an update atm. But you can install it to try if 6.4.X solves your issue:

dnf update

Only use this kernel to check out if it works without the issue. Do not use that kernel to work (at least, do not yet rely on its stability). At the best, after testing to check if it works, reboot with the newest one that works for you and directly remove 6.4.2 again until it is added as official stable update.

Thanks for the reply. I’ve never manually installed a kernel before. To remove it after testing, would I just run the following?

dfn remove kernel-6.4.2-201.fc38.x86_64.rpm kernel-core-6.4.2-201.fc38.x86_64.rpm kernel-modules-6.4.2-201.fc38.x86_64.rpm kernel-modules-core-6.4.2-201.fc38.x86_64.rpm kernel-modules-extra-6.4.2-201.fc38.x86_64.rpm

sudo dnf remove kernel*6.4.2* probably would do that successfully.

Thank you for the suggestion. Unfortunately, the result was the same with the 6.4.2-201.fc38 kernel -a blank screen then my monitor turning on and off repeatedly. I was able to do a quick uninstall with Jeff’s command.

Does it matter that it was a fc38 kernel, and not a fc37 kernel? I am running Fedora 37.

I will see if I can find a display port cable to test instead of HDMI.

Yes, f38 kernels can work on f37, but it can also happen that they don’t. However, it was still worth a try and it does not cause any harm but the f37/f38-difference can also explain that it does not work with F37. This means, we don’t know if 6.4.2 solves your issue. Unfortunately, we do not yet have a 6.4.2 build for F37. However, when you tested the F38 6.4.2, did it behave exactly the same as the 6.3 kernels? Could you experience any difference? This might give a hint if the 6.4.2 did not work because f37/f38 or because of your issue.

Worth a try. Let us know. Feel free to try different settings (on battery → plugged in; hdmi → display port; with and without external monitor in cases of laptops; and so on).

Beyond that, I would say this is worth a bug report, but I am not convinced if a F37 report will have a high priority given that there are several other reports open and that we are on the way to migrate to 6.4.X (causing additional work to the kernel team). But if you want, you can read my comment here about how to create a bug report about the issue (make sure to choose f37) and what to consider in the report.

However, this of course leads to the next alternative which could be indeed successful: update to F38. Maybe that’s worth a try before a bug report?

Unfortunately, the time I can invest at the moment is limited.

I just bought a Display Port cable and surprisingly, it works!

I am running kernel 6.3.8-100.fc37.x86_64 without any issues. I don’t know why, but it does work :smile:

I feel confident about deleting the old kernel and upgrading to F38. I might test HDMI in F38 just to see if the bug persists.

Thanks for all your help

Cool that it works now! I suggest to wait for the 6.4.X kernels and then test again.

I saw today that the current 6.4.3 seems to solve several issues related to AMD GPU. Maybe yours will be included as well.

I expect that Fedora will switch to 6.4.X soon (my expectation is 6.4.3 or 6.4.4 to be the first 6.4 kernels that go stable). If that will not solve the issue with HDMI, a test with F38 is interesting, too.

Feel free to keep us updated. It is good to have the issue mitigated, but forcing people to not use HDMI or so should not be a long term solution. So let’s hope that F38 or kernel 6.4.X will solve the issue in general.