Black screen with cursor after messing with amdgpu-install trying to install rocm for stable diffusion

Problem solved for me, just want to save someones time
So I wanted to tryout stable diffusion using my rx 6700, installed a lot of packages and in the end nothing worked and I even broke my gpu driver.

Don’t know which steps helped exactly, in my opinion last one is the most important. (just a list of what I did)
When You see black screen with cursor, use CTRL+ALT+F3 to enter console mode.

  1. amdgpu-uninstall and/or amdgpu-install --uninstall
  2. sudo depmod -a
  3. reboot
  4. make sure you’ve got the driver installed:
    dnf in xorg-x11-drv-amdgpu vulkan-tools mesa-vulkan-drivers
    5. add undermentioned kernel parameters
    grubby --update-kernel=ALL --args="radeon.cik_support=0 amdgpu.cik_support=1"
  5. reboot
  6. most important in my opinion I have same system on my laptop, so I just run dnf list installed | grep amd and uninstalled everything that was NOT on this list
$ dnf list installed | grep amd
amd-gpu-firmware.noarch                            20231211-1.fc39                     @updates                                         
amd-ucode-firmware.noarch                          20231211-1.fc39                     @updates                                         
teamd.x86_64                                       1.32-1.fc39                         @fedora                                          
xorg-x11-drv-amdgpu.x86_64                         23.0.0-2.fc39                       @fedora  

And after another reboot, it was back to normal. :tada:

Here is some uninstall history

  965  sudo dnf remove xorg-x11-amdgpu-drv-amdgpu-1:24.1.0-1697589.el9.x86_64 
  974  sudo dnf remove libdrm-amdgpu
  976  sudo dnf remove libdrm-amdgpu-common
  978  sudo dnf remove libdrm-amdgpu-client
  979  sudo dnf remove libwayland-amdgpu
  981  sudo dnf remove llvm-amdgpu-libs
  984  sudo dnf remove mesa-amdgpu-dri-drivers
  985  sudo dnf remove mesa-amdgpu
  987  sudo dnf remove mesa-amdgpu-file
  989  sudo dnf remove '*mesa-amdgpu*'
  991  sudo dnf remove libwayland-amdgpu-client
  992  sudo dnf remove libwayland-amdgpu-server

dnf search rocm
Last metadata expiration check: 
2 days, 23:54:23 ago on Sun 14 Jan 2024 11:04:49 AM EST.
======================= Name & Summary Matched: rocm =======================

rocm-clinfo.x86_64 : ROCm OpenCL platform and device tool
rocm-comgr.x86_64 : AMD ROCm LLVM Code Object Manager
rocm-comgr-devel.x86_64 : AMD ROCm LLVM Code Object Manager
rocm-device-libs.x86_64 : AMD ROCm LLVM bit code libraries
rocm-hip.x86_64 : ROCm HIP platform and device tool
rocm-hip-devel.x86_64 : ROCm HIP development package
rocm-opencl.x86_64 : ROCm OpenCL platform and device tool
rocm-opencl-devel.x86_64 : ROCm OpenCL development package
rocm-runtime.x86_64 : ROCm Runtime Library
rocm-runtime-devel.x86_64 : ROCm Runtime development files
rocm-smi.noarch : AMD ROCm System Management Interface
rocm-smi.x86_64 : ROCm System Management Interface Library
rocm-smi-devel.x86_64 : ROCm SMI Library development files
rocminfo.x86_64 : ROCm system info utility

All you wanted to do was install ROCm ? It’s in the repos. . . I’m more curious as to how you got to that point of a broken driver :thinking:

Maybe should not have used RHEL instructions :upside_down_face: Quick-start install guide — ROCm installation (Linux)

Probably will try again at some point with your way, thanks.