Black screen on resume

When resuming from hibernate or suspend, I am confronted with a black screen. There seems to be some activity, as my Wi-Fi light turns on too. After a force-reset, there’s no logging of the resumption in the journal.

I use a Lenovo Thinkpad P53 with an Nvidia T1000 GPU, so I’m running Optimus. I run F37 Silverblue, which was previously upgraded from F36 Silverblue.

fpaste --sysinfo:
journalctl -b -1 -n 83:

Did this ever happen on your F36 Silverblue install? It seems like a lot of the black screens after hibernating/suspending in Fedora, generally, is due to a kernel issue and with Silverblue, specifically, with upgraded packages.

Perhaps a rpm-ostree rollback or rpm-ostree ex reset is in order, but I know very little about Silverblue and, so, someone more versed may have a better idea or option.

I’ve checked, (as I luckily pinned F36 just before upgrading to F37) and it shows the same behaviour. I did notice that it didn’t do it the first time I tried (before I booted Firefox to respond to your comment), but then I tried again after booting firefox, and it did result in a blackscreen. Perhaps memory usage or uptime has some kind of influence on it. I’ll mess about some more to see if I can narrow this down to circumstance.

Edit: It seems very consistent that when I close my lid very quickly after booting, it is able to resume from sleep afterward, however when I wait only about a minute after boot before closing my lid, it then fails to resume.

So, after scouring through Systemd’s logging, it seems that TLP was enabled. It booted quite slowly, thus explaining why entering sleep very quickly after boot did resume properly. After waiting a while, TLP got the chance to boot, and prevented resumption. I thought I’d disabled TLP a while ago, but it seems it got re-enabled somehow again.

Glad you solved this one!