Black Screen on fresh install F34

Hi, I was planning to try Fedora but the problems that I encountered are now so many. Fortunately, I succeed to install Fedora with a fresh install in dual boot with Windows using Legacy Boot Mode (MBR and not UEFI). After selecting Fedora on GRUB, it remains on a black screen permanently, with a blinking white cursor. I tried so many solutions founded here, like adding “nomodeset=0” to the GRUB options but nothing works. I would like to give to Fedora last chance, but idk what I could try to do

Which Installation Media you are using for the installation?

What is the graphic chip in your system?

I used a USB stick for the installation. As GPU I have an integrated Intel (Intel Graphics HD 520)

I want to know which ISO file you have written to the USB for the installation?

Have you tried it with disable secure boot in the bios settings? It looks to me like that may be the problem.
Seems to be a code signing problem…(I’m not an expert on that, but dual-boot is always problematic. I would recommend to setup the Windows system first with it’s 2 partitions on a MBR-based system and afterwards the fedora system. I always used the automatic partitioning scheme, that should normally not lead to a problem, at the most it can lead to a duplicated boot partition, which should not lead to any problems. At least that’s my experience. Some bios-es are very stubborn, so that can lead to problems. Dual boot can be problematic sometimes.

Fedora Workstation 34 (GNOME Version)

I’ll try it in a couple of minutes and then I will post here an update

1 Like

I’m normally a bit reluctant in posting my computer details in an open forum, since everyone can read and hence will edit my posting later.

The secure boot was already disabled, unfortunately

1 Like

Good luck anyways! Hope you will find a way to get it running on a dual-boot system.

Probably I resolved updating my BIOS Firmware

1 Like

Take your time. A freshly updated bios is always a good idea.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.