Black screen issue when booting fedora Asahi remix 39, while the external hdmi monitor work

I am using Macbook Pro M1 Pro running Mac OS 14.3 and I face issue when booting fedora asahi remix 39, the built in display turns black while the external monitor works, I have tried to solve this issue using nomodeset, and nomodeset solved this issue partially by making the built in display work and externel hdmi monitor continue to work as normal, but nomodeset disables the apple m1 pro gpu, and the system uses software rendering instead of the gpu.

On other hand while I was searching for a solution, I found the rescue mode, I tried it and got this message
“apple-dcp 289c00000.dcp: Failed to get dp-xbar: -517”.

This happens when the system booted without adding nomodeset to grub.

The good news is the external monitor which is plugged in using hdmi was working, as well the Apple M1 Pro (G135 CO) gpu, except the built in display it was black, all of this happened when the system booted without nomodeset added to grub.

the summary of the issue:

when nomodeset added to grub:

  • built in display and externel monitor is going to work.
  • apple m1 pro gpu is going to be disabled and the system is going to use software rendering instead.

when the system boot without nomodeset added to grub:

  • apple m1 pro gpu and the external will work fine.
  • the built in display is going to be black.

I hope there is a solution for this issue.

here is a link in gist.github for the boot log :
boot log

From Ask Fedora to Ask Asahi

I have solved this issue by downgrading to Mac OS 13.6 using DFU mode, I am not an expert to say the real cause of this problem but I believe there is a firmware issue in Mac OS Sonoma that cause the screen to be black.