Black screen after installing nvidia driver on desktop

Hello all. I’m here to look for help.

So, I am running Debian stable and wanted to switch to Fedora, but I can’t figure out how to make the nVidia driver work. Whatever tutorial I follow, I end up with a black screen and often no video signal at all.

I have an i5-9600K and RTX 2070. And the screen is a Samsung TV.
It doesn’t work with nouveau. So I have to switch to integrated graphics, then install and configure things, and then reboot and switch to dedicated to test it. And then it doesn’t work. Yes, my card was on the list, when I did lspci in Fedora.

I pretty much ran out of tutorials. What can I do to make it work?
I will post any additional information needed. Thank you.

Here’s the Xorg log from my latest try:

(Yes, the TV is correctly connected.)

Hello aurora,

can you tell us a little more how you tried to install the nvidia driver? What tutorial did you use?

Looking at the Xorg.log I read:

[ 32.840] (WW) Warning, couldn’t open module nv

So it looks like your nvidia module is not built well and/or installed.

I have installed everything using the auto install tool from here:
Then rebooted, switched to dGPU in EFI, started up Fedora and got “No Signal” on the TV.

Could you share the output (text or screenshot) of the installer?
Or maybe post your experiences in the thread you mention?

Switching to the discrete GPU and having the display enabled requires you to enable the prime configuration - something which is not taken care of by the installer. Please read this and this to obtain a prime configuration on a workstation installation.

@t0xic0der No, since I’m disabling the iGPU completely in the EFI.

@rele Now I feel dumb… I googled that warning. I found a question, where someone suggested updating initramfs.
I ran sudo dracut -f /boot/initramfs-<My kernel>.img and it just worked…

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.