Battery running down fast in standby mode

F40WS on a Dell 5420. I noticed the battery is flat every time I open it so I tested it and the battery drops from 100% to around 50% in 3-4 hours with lid closed in standby. I had this with another machine and had to roll back to an older kernel which someone advised me how to do. Wondering if I need to do the same thing with this machine, any advice appreciated.
thanks

This sounds like one of two possibilities.

  1. The machine is not actually in standby but is still running normally.
    This would require making sure it is actually suspending and not just a blank screen with the OS still running. The logs should show that.

  2. The battery is failing with reduced capacity and even the standby mode still drains it quickly.
    How long does the machine run on battery when it starts at full charge and is used throughout the day?

You will need to identify the actual situation and then fix it appropriately.

If you are closing the lid usually, I would advice to first try suspending like if it was desktop from menu.

3 Likes

I should have said, the battery is good. Very little used and I get good usage times when running on battery, i am sure it’s not a battery issue. I had this with a Yoga which was brand new from factory, battery died away rapidly in standby.

I am also pretty sure it is in standby (screen black and wants password instantly if i close lid, and network activity stops) so I am 99% sure it is going into suspend mode as it should when lid is closed.

I don’t know what or where logs are, but really think this is same issue as I had on Yoga, its power hungry in standby. Any ideas if thats the case?
thanks

Would be very grateful if someone could advise if this is a kernel issue please

This could help:

There are a couple ways to check the logs after you wake from suspend. If you can reproduce the issue consistently :

Screenshot from 2024-06-23 14-47-09

Or you can, from the terminal try journalctl -xe | fpaste --raw-url This will produce a url you can paste here for us to look through in case the output is too long.

This is what I typically do, I believe it happened to me once or twice on this Laptop. Out of habbit before I close the lid, I go through the menu, and wait the 2-3 seconds for the light to go off.

If it does not happen on an older kernel, that it’s possible it’s a kernel issue. although verifying that and going through the logs would be required.

Having similar phenomenon here (F40 KDE Spin, but I think it started with F39; Lenovo X280).

Not really reproducible, but from time to time the battery drain looks higher than usual (like it is only ‘half’ sleeping):

  • If I perform a suspend from GUI, then things look good.
  • If I close lid, higher battery drain happening from time to time
  • It feels like If I keep lid open and wait for suspend to kick in, the drainage effect seems a bit higher (I remember having spotted some aborted suspends in the journal some while ago)

But no real facts, as I could not find the needle in the logstack. I thought this is related to different kind of suspend modes.

[EDIT]: Sometimes I can wake up my laptop by simply pressing a key on the keyboard, sometimes I need to push the power button. In both cases, the power button shows a pulsating white light.

1 Like

I have tried suspending manuall, no different, very high battery drain while lid closed. BUT, I didn’t ‘wait’ for lights to go off, I probably closed lid within half a second to a second after suspending machine.

I will try this suggestion of sleeping it and waiting for lights to go off before closing lid, and monitor battery usage. Will report back, and thanks for tip on getting link to logs (are those privacy-redacted or should I be careful posting such links/info?)

thanks

They are safe to use, also the link is only active for 24hrs, per Fedora’s policy.

1 Like

There have been changes to kernel power management support (driven by certification requirements needed to sell to large enterprises). These may require vendor firmware updates to work properly. Please check that your system is fully updated with sudo fwupdtool get-updates (or using vendor site and tools). In Canada I have noticed lags behind availability in the US (maybe waiting for French translations).

1 Like

Thanks. I ran that and here is the output, if you’re able to translate I’d be grateful!

Loading…                 [*************                          ]13:40:50.783 FuUsbDevice          failed to parse platform BOS descriptor: failed to parse: no supported platform version: did not find magic
Loading…                 [************************************** ]
Devices with no available firmware updates: 
 • CT1000MX500SSD4
 • StarTech DK30CH2DPPD
 • TPM
 • UEFI Device Firmware
Devices with the latest available firmware version:
 • System Firmware
 • UEFI dbx
No updates available for remaining devices

Looks like you aren’t missing any available updates.

You can use journalctl to look for differences between the various ways of suspending/waking. It may be useful to record the times when these actions occur. I would start with just journalctl -b, skip to one of the action times, and try to identify search terms that mark suspend and wake (my Fedora systems are desktops that run 7x24) so can’t look for terms here. With those search terms and the action times you can look for differences in messages after initiating suspend or resume.

Thanks but as always I am really struggling to understand that. I have never looked at a ‘journal’.
‘Identify search terms’?

I did type in journalctl -b and saw the output (65 lines). I can’t make head nor tail of it.

Are you suggesting I sleep the machine and make a note of the time, then wake it and type that command again, looking for the time I suspended the machine and seeing what it says around that time?

journalctl is a terminal app to browse the systemd journal. It is widely used across many linux distributions, so not specific to Fedora. The journal collects a massive amount of detail of which 99% will be normal progress reports. I generally add --no-hostname to eliminate on bit of information I don’t need to see. It is worth learning because the next time you have an issue you will be able to provide relevant details.

Read man journalctl (in a terminal) for explanations of the options. I get over 2000 lines for journalctl -b immediately after booting. You should be able to scroll the display to see more than 65 lines, and horizontally to see the rest of very long lines. You can enter /<search term> to jump to a line that contains <search term>.

Some links:

Thanks, that helps.
But could you also comment on my question about what I should actually do this end? Should I put machine into sleep then go back and look in journal for that time period to look for stuff to paste in here?
thanks again

Yes. You could save time with a binary search – disabling half of the extensions to see if one group works properly, then half of the “bad” group. I would first focus on the one that aren’t from Fedora packages under the assumption others would have found issues with Fedora packages.

I have absolutely no clue what you just said.
Binary search? Extensions, what extensions? This thread is about the machine sleeping and using battery, in case you accidentally posted on wrong thread

I agree. Looks like he posted in the wrong thread. It looks like @gnwiii was answering a question in this thread: Cannot enable any extension after 39 > 40 upgrade

1 Like

Phew, panic over, underwear being changed shortly :smiley:

thanks

1 Like