Bad package on mirrors

Making a local mirror of fedora 32 releases Everything, and there’s a package which fail basic rpm checks.
sagemath-doc-en-9.0-2.fc32.x86_64.rpm: headerRead failed: hdr data: BAD, no. of bytes(45864464) out of range
I tried several source mirrors, and all of them fail on this rpm.

I’ve downloaded the package from koji and from a couple of mirrors in Europe. I ran createrepo_c, rpm2cpio and rpmlint on all of them, there was no problem. What exactly are you doing?


I’m just using reposync to get a local mirror for my internal network. I also just did curl from a few mirrors and rpm -K, fails every time.

1 Like

With the package from koji:

$ rpm -K sagemath-doc-en-9.0-2.fc32.x86_64.rpm 
sagemath-doc-en-9.0-2.fc32.x86_64.rpm: digests signatures OK
$ rpm --version
RPM version 4.15.1

Checking the sha256 checksum against what’s in repodata (primary.xml):

$ cat 54d993893d048deb40a73064667093159c32942c59ec7664c0149ba55c8da883-primary.xml | grep -A 5 sagemath-doc-en | grep checksum
  <checksum type="sha256" pkgid="YES">d84da9f47c9282fa398f7956324fd48afbfd93d35ab259619e331a844feb717a</checksum>

$ sha256sum sagemath-doc-en-9.0-2.fc32.x86_64.rpm 
d84da9f47c9282fa398f7956324fd48afbfd93d35ab259619e331a844feb717a  ./sagemath-doc-en-9.0-2.fc32.x86_64.rpm

I think your problem lies elsewhere.

Wow, that is really weird… okay it does seem to be something local.

1 Like

Well, there it is. The mirror server was on Cent 7.2 rpm 4.11.3-17.el7. I got another system Cent 7.7 rpm 4.11.3-35.el7 which didn’t have the problem. I updated the mirror server and poof, error gone.
That’s pretty odd though that just this one package tripped up the older rpm version. Oh well…

I’ve occasionally seen something similar. At those times, the file on the mirror was for some reason incorrect, but reposync believed in it and didn’t update it. Possibly a failed download the first time.

Removing the file on the mirror caused a new download in these cases. It forced reposync to redownload the packages.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.